This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 158188

Summary: rpc.idmapd error at bootup
Product: [Fedora] Fedora Reporter: Joe Orton <jorton>
Component: nfs-utilsAssignee: Steve Dickson <steved>
Status: CLOSED CURRENTRELEASE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: andreas.bierfert, njh, notting, sergio, sundaram, tibyke, vlado_potisk
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1:1.0.8-3 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-10-31 09:37:39 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 136450    

Description Joe Orton 2005-05-19 10:08:39 EDT
Raw Hide kickstart from today,

# rpm -qf /usr/sbin/rpc.idmapd
nfs-utils-1.0.7-6

sees this unhealthy looking message in /var/log/messages after bootup:

May 19 14:58:56 sprite rpc.idmapd: nfsdreopen: Opening 'ib/nfs/rpc_pipefs/nfs'
failed: errno 2 (No such file or directory)
May 19 14:58:56 sprite rpc.idmapd: nfsdreopen: Opening '' failed: errno 2 (No
such file or directory)
Comment 1 Bill Nottingham 2005-05-24 17:03:31 EDT
I'm not seeing this on a fresh install here. Are you mounting nfsv4 filesystems?
Comment 2 Joe Orton 2005-05-24 17:14:51 EDT
Nope.

# grep nfs /proc/mounts
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0
nfsd /proc/fs/nfsd nfsd rw 0 0
tantra:/export/mirror /netopt/mirror nfs
rw,v3,rsize=8192,wsize=8192,soft,intr,udp,lock,addr=tantra 0 0
file:/home/jorton /home/jorton nfs
rw,v3,rsize=8192,wsize=8192,soft,intr,udp,lock,addr=file 0 0
Comment 3 Bill Nottingham 2005-05-24 17:40:22 EDT
Does this come from a) you logging in b) something connectiong to your server?
Comment 4 Joe Orton 2005-05-25 02:58:29 EDT
It occurs immediately at boot, before I log in; same problem with yesterday's
Raw Hide install.

May 25 00:59:21 trash kernel: Installing knfsd (copyright (C) 1996
okir@monad.swb.de).
May 25 00:59:21 trash kernel: SELinux: initialized (dev nfsd, type nfsd), uses
genfs_contexts
May 25 00:59:21 trash rpc.idmapd: nfsdreopen: Opening 'ib/nfs/rpc_pipefs/nfs'
failed: errno 2 (No such file or directory)
May 25 00:59:21 trash rpc.idmapd: nfsdreopen: Opening '' failed: errno 2 (No
such file or directory)
Comment 5 Bill Nottingham 2005-05-25 12:11:26 EDT
What's your /etc/exports (and any other relevant NFS server config)?
Comment 6 Steve Dickson 2005-05-25 15:50:25 EDT
Is /var/lib/nfs/rpc_pipefs mounted? Also are your starting the NFS server?
Comment 7 Bill Nottingham 2005-05-25 15:54:55 EDT
I can reproduce it now; yes, it's mounted. The error occurs when the nfs server
starts.
Comment 8 Joe Orton 2005-05-25 17:48:53 EDT
For the record, nfs is chkconfig'd on and /ext/exports has:

/local  172.16.18.0/24(rw,async)

# grep nfs /proc/mounts
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0
nfsd /proc/fs/nfsd nfsd rw 0 0

though I have no idea what is mounted at the time the nfs server starts during boot.
Comment 9 Jeremy Katz 2005-05-26 23:15:20 EDT
Steve built 1.0.7-8 to fix this
Comment 10 Ted Kaczmarek 2005-09-10 10:33:18 EDT
[root@inyoureyes log]# rpm -q nfs-utils
nfs-utils-1.0.7-11

 cat /etc/exports
/exports 192.168.1.22(rw,sync)


rpc.idmapd: nfsdreopen: Opening '' failed: errno 2 (No such file or directory)

[root@inyoureyes log]# grep nfs /proc/mounts
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0
nfsd /proc/fs/nfsd nfsd rw 0 0

See this on restarts, otherwise appears to be functioning.
Comment 11 Steve Dickson 2005-09-11 07:37:16 EDT
Please change OPTIONS="" to OPTIONS="-vvv" in the 
/etc/init.d/rpcidmapd startup script and then try
to reproduce the problem and post the output.
Comment 12 josip 2005-09-30 12:23:22 EDT
I have the same problem with FC4 and nfs-utils-1.0.7-11.  Portmapper is running,
nfs is running, /etc/idmapd.conf and /etc/exports look correct, but when clients
reboot, their mounts sometimes fail.  Server log shows that mount requests were
authorized but the client can't access the NFS mount point anyway.
Comment 13 josip 2005-10-04 10:59:33 EDT
Clarification: When my clients reboot, they umount the NFS filesystems normally,
then try to remount them about 2.5 minutes later -- and this sometimes fails. 
The server always reports "rpc.mountd: authenticated mount request ..." but the
client hangs for a couple of minutes then times out, complaining that it could
not read the NFS filesystem's superblock.

Failed NFS mounts are fixed immediately by restarting portmap and/or nfs on the
server, or sometimes even by trying mount again after 10-15 minutes.

Is it possible that the NFS server is using some stale connection info which
times out and resets after 10-15 minutes?  I can't decide if nfs, nfslock,
rpc.idmapd, or portmap is at fault.

Meanwhile, "rpc.idmapd: nfsdreopen: Opening '' failed: errno 2 (No such file or
directory)" is reported in my logs any time rpc.idmapd is started.
Comment 14 Steve Dickson 2005-11-01 06:29:47 EST
Ok I did find a problem in the rpc.idmapd starting up and should
be fixed with the nfs-utils in Rawhide. Please update.
Comment 15 Sergio Monteiro Basto 2005-11-08 15:02:58 EST
Hi, testing this inssue with
(rpm -q nfs-utils)
nfs-utils-1.0.7-12.FC4
 and putting -vvv on options I got 
Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
NFSD: recovery directory /var/lib/nfs/v4recovery doesn't exist
NFSD: starting 90-second grace period
nfsd: last server has exited
nfsd: unexporting all filesystems
NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
NFSD: recovery directory /var/lib/nfs/v4recovery doesn't exist
NFSD: starting 90-second grace period 
Comment 16 Sergio Monteiro Basto 2005-12-01 20:20:10 EST
I had emailed to nfsv4@linux-nfs.org and got this reply, 

From: "J. Bruce Fields" <bfields@fieldses.org>
On Wed, Nov 23, 2005 at 01:24:18AM +0000, Sergio Monteiro Basto wrote:
> I got
> NFSD: recovery directory /var/lib/nfs/v4recovery doesn't exist
> if doesn't exist shouldn't be created ?
> ok I created directory myself, but what owner and permitions should have ?
> root:root 755 is good ?

Sure.

You need that directory for server reboot recovery to work.

Note that there's unfortunately some disagreement over whether the
current interface is correct, so it may change in the near future.

--b.

and I have been test nfs-utils-1.0.7-19.FC5 recompiled for my Fedora Core 4
sucefully 

Comment 17 Nigel Horne 2006-01-09 01:46:28 EST
I have the same problem.

# fgrep nfs /proc/mounts
[root@bandsman sysconfig]# fgrep nfs /proc/mounts
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0
nfsd /proc/fs/nfsd nfsd rw 0 0
[root@bandsman sysconfig]# cat /etc/idmapd.conf
[General]

Verbosity = 0
Pipefs-Directory = /var/lib/nfs/rpc_pipefs
Domain = localdomain

[Mapping]

Nobody-User = nobody
Nobody-Group = nobody

[Translation]
Method = nsswitch
[root@bandsman sysconfig]# cat /etc/exports
#
/       192.168.1.0/255.255.255.0(sync,insecure,no_root_squash,rw)
/var    192.168.1.0/255.255.255.0(sync,insecure,no_root_squash,rw)  
[root@bandsman sysconfig]# fgrep "''" /var/log/messages
Jan  9 06:40:22 bandsman rpc.idmapd: nfsdreopen: Opening '' failed: errno 2 (No
such file or directory)
[root@bandsman sysconfig]# rpm -q nfs-utils
nfs-utils-1.0.7-12.FC4
Comment 18 Andreas Bierfert 2006-01-21 05:53:56 EST
Same here... will this be fixed for fc4?
Comment 19 tibyke 2006-02-08 19:56:01 EST
I do have exactly the same problem on FC4 with nfs-utils-1.0.7-12.FC4

relevant part of /etc/exports:

/home/web/foo/kepek  192.168.2.4(rw,no_root_squash,sync)
/home/web/bar     192.168.2.4(rw,no_root_squash,sync)
/home/web/modul     192.168.2.4(rw,no_root_squash,sync) 

syslog:

Feb  9 01:23:49 images kernel: Installing knfsd (copyright (C) 1996
okir@monad.swb.de).
Feb  9 01:23:49 images kernel: NFSD: Using /var/lib/nfs/v4recovery as the NFSv4
state recovery directory
Feb  9 01:23:49 images kernel: NFSD: starting 90-second grace period
Feb  9 01:26:19 images rpc.idmapd: nfsdreopen: Opening '' failed: errno 2 (No
such file or directory)

the funny thing is that since a couple of days nfs service starts extremely
slowly (5-6 minutes or even more)
i have /var/lib/nfs/v4recovery (i made it long before myself)

just tried /etc/init.d/nfs restart:
real    5m6.177s
user    0m0.096s
sys     0m0.276s

relevant part:
Feb  9 01:55:16 images rpc.mountd: Caught signal 15, un-registering and exiting.
Feb  9 01:55:21 images kernel: nfsd: last server has exited
Feb  9 01:55:21 images kernel: nfsd: unexporting all filesystems
Feb  9 01:55:21 images kernel: RPC: failed to contact portmap (errno -5).
Feb  9 01:56:05 images init: Trying to re-exec init
Feb  9 01:57:52 images kernel: NFSD: Using /var/lib/nfs/v4recovery as the NFSv4
state recovery directory
Feb  9 01:57:52 images kernel: NFSD: starting 90-second grace period
Feb  9 02:00:22 images rpc.idmapd: nfsdreopen: Opening '' failed: errno 2 (No
such file or directory)
Comment 20 Steve Dickson 2006-07-25 16:26:41 EDT
/var/lib/nfs/v4recovery is now created with the latest FC5 nfs-utils.
Comment 21 Sergio Monteiro Basto 2006-10-25 19:56:42 EDT
this bug could be closed