Bug 1582189

Summary: Cannot run valgrind
Product: [Fedora] Fedora Reporter: Milan Crha <mcrha>
Component: glibcAssignee: Carlos O'Donell <codonell>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 28CC: aoliva, arjun.is, codonell, dj, fweimer, law, mfabian, pfrankli, rth, siddhesh
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-05-24 13:19:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Milan Crha 2018-05-24 13:15:07 UTC
I only recently upgraded to Fedora 28 from Fedora 27. I have installed:

glibc-2.27-14.fc28.i686
glibc-2.27-14.fc28.x86_64
glibc-common-2.27-14.fc28.x86_64
glibc-devel-2.27-14.fc28.x86_64
glibc-headers-2.27-14.fc28.x86_64
glibc-langpack-en-2.27-14.fc28.x86_64
valgrind-3.13.0-18.fc28.x86_64

Trying to run:

   $ valgrind /usr/bin/echo

results in an error from valgrind:

----------------------------------------------------------------------------

==13043== Memcheck, a memory error detector
==13043== Copyright (C) 2002-2017, and GNU GPL'd, by Julian Seward et al.
==13043== Using Valgrind-3.13.0 and LibVEX; rerun with -h for copyright info
==13043== Command: /usr/bin/echo
==13043== 

valgrind:  Fatal error at startup: a function redirection
valgrind:  which is mandatory for this platform-tool combination
valgrind:  cannot be set up.  Details of the redirection are:
valgrind:  
valgrind:  A must-be-redirected function
valgrind:  whose name matches the pattern:      strlen
valgrind:  in an object with soname matching:   ld-linux-x86-64.so.2
valgrind:  was not found whilst processing
valgrind:  symbols from the object with soname: ld-linux-x86-64.so.2
valgrind:  
valgrind:  Possible fixes: (1, short term): install glibc's debuginfo
valgrind:  package on this machine.  (2, longer term): ask the packagers
valgrind:  for your Linux distribution to please in future ship a non-
valgrind:  stripped ld.so (or whatever the dynamic linker .so is called)
valgrind:  that exports the above-named function using the standard
valgrind:  calling conventions for this platform.  The package you need
valgrind:  to install for fix (1) is called
valgrind:  
valgrind:    On Debian, Ubuntu:                 libc6-dbg
valgrind:    On SuSE, openSuSE, Fedora, RHEL:   glibc-debuginfo
valgrind:  
valgrind:  Note that if you are debugging a 32 bit process on a
valgrind:  64 bit system, you will need a corresponding 32 bit debuginfo
valgrind:  package (e.g. libc6-dbg:i386).
valgrind:  
valgrind:  Cannot continue -- exiting now.  Sorry.

----------------------------------------------------------------------------

The debuginfo was not needed in Fedora 27, as far as I can tell.

Installing corresponding glibc-debuginfo (x86_64 version only) did help.

Comment 1 Florian Weimer 2018-05-24 13:19:13 UTC

*** This bug has been marked as a duplicate of bug 1570246 ***