Bug 1584591

Summary: gnocchi_api and gnocchi_metricd don't bind host's /var/lib/gnocchi directory
Product: Red Hat OpenStack Reporter: Mehdi ABAAKOUK <mabaakou>
Component: openstack-tripleo-heat-templatesAssignee: Mehdi ABAAKOUK <mabaakou>
Status: CLOSED ERRATA QA Contact: Sasha Smolyak <ssmolyak>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 13.0 (Queens)CC: abishop, apannu, cchen, dbecker, dprince, jcoufal, jschluet, knakai, lnatapov, mabaakou, m.andre, mburns, pkilambi, sclewis, ssmolyak, tyasuma
Target Milestone: rcKeywords: Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-8.0.2-29.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1559920 Environment:
Last Closed: 2018-06-27 13:57:08 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1559920    
Bug Blocks:    

Comment 14 Leonid Natapov 2018-06-05 12:49:10 UTC
1.(overcloud) [stack@undercloud-0 ~]$ openstack metric measures show --resource-id 5eaf3f11-45e4-4da4-9766-ae7bf4c7b778 cpu
+---------------------------+-------------+---------------+
| timestamp                 | granularity |         value |
+---------------------------+-------------+---------------+
| 2018-06-05T08:15:00-04:00 |       300.0 | 15870000000.0 |
| 2018-06-05T08:20:00-04:00 |       300.0 | 24310000000.0 |
| 2018-06-05T08:25:00-04:00 |       300.0 | 28710000000.0 |
| 2018-06-05T08:30:00-04:00 |       300.0 | 29260000000.0 |
| 2018-06-05T08:35:00-04:00 |       300.0 | 30020000000.0 |
| 2018-06-05T08:40:00-04:00 |       300.0 | 30560000000.0 |
+---------------------------+-------------+---------------+

2.[root@controller-0 heat-admin]# docker stop gnocchi_metricd
gnocchi_metricd
[root@controller-0 heat-admin]# docker start gnocchi_metricd
gnocchi_metricd

3.(overcloud) [stack@undercloud-0 ~]$ openstack metric measures show --resource-id 5eaf3f11-45e4-4da4-9766-ae7bf4c7b778 cpu
+---------------------------+-------------+---------------+
| timestamp                 | granularity |         value |
+---------------------------+-------------+---------------+
| 2018-06-05T08:15:00-04:00 |       300.0 | 15870000000.0 |
| 2018-06-05T08:20:00-04:00 |       300.0 | 24310000000.0 |
| 2018-06-05T08:25:00-04:00 |       300.0 | 28710000000.0 |
| 2018-06-05T08:30:00-04:00 |       300.0 | 29260000000.0 |
| 2018-06-05T08:35:00-04:00 |       300.0 | 30020000000.0 |
| 2018-06-05T08:40:00-04:00 |       300.0 | 30560000000.0 |
+---------------------------+-------------+---------------+

Comment 16 errata-xmlrpc 2018-06-27 13:57:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086