Bug 1591288

Summary: [RFE] Enable node replacement for OpenShift deployed via director
Product: Red Hat OpenStack Reporter: Steven Hardy <shardy>
Component: openstack-tripleoAssignee: Steven Hardy <shardy>
Status: CLOSED WONTFIX QA Contact: Arik Chernetsky <achernet>
Severity: high Docs Contact:
Priority: medium    
Version: 15.0 (Stein)CC: ltomasbo, mburns, oblaut, racedoro, tsedovic
Target Milestone: Upstream M2Keywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-05-13 08:55:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1565995    
Bug Blocks:    

Description Steven Hardy 2018-06-14 13:28:22 UTC
Description of problem:
Related to https://bugzilla.redhat.com/show_bug.cgi?id=1565999 and https://bugzilla.redhat.com/show_bug.cgi?id=1565995

We need to handle node replacement on update when deploying OCP voa director - currently the inventory/playbook generated is tailored to the initial deployment and we may need additional steps to handle the removal/replacement of nodes.

Comment 2 Luis Tomas Bolivar 2019-05-13 08:55:57 UTC
Closing as WONTFIX as we'll deprecate Director deployed OCP in OSP15: https://bugzilla.redhat.com/show_bug.cgi?id=1702694