Bug 1592384

Summary: [ppp] Drop requirements for 'initscripts' from specfile
Product: [Fedora] Fedora Reporter: David Kaspar [Dee'Kej] <dkaspar>
Component: pppAssignee: Jaroslav Škarvada <jskarvad>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: rawhideCC: jaskalnik, jskarvad, jsynacek, msekleta, thozza
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: ppp-2.4.7-23.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-20 10:00:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1592330    

Description David Kaspar [Dee'Kej] 2018-06-18 13:23:18 UTC
Hello!

Description of problem:
It appears your package depend on 'initscrits' package for some reason. However, most of the initscripts' dependants are no longer valid.

I hereby request you check your package/specfile, and either:
 * drop the initscripts dependancy and close this BZ, or
 * provide a justification in a comment for keeping the dependancy (without closing this BZ)

----------------------

NOTE: In case you are depending on initscripts because of networking scripts, then you will need to update your specfile to depend directly on new package 'network-scripts' (instead of 'initscripts').

If this is the case, please let us know in the comments and do not close the BZ  yet.

Additional info:
The requested change here is valid for Rawhide (F29) only. Do not backport these changes into F28 or F27, because it would break things.

Thank you for your co-operation! :)

 -- Dee'Kej --

Comment 1 Jaroslav Škarvada 2018-06-20 09:55:32 UTC
It's for '/etc/sysconfig/network-scripts', it seems this directory is in f29 provided by the network-scripts package (previously it has been provided by the initscripts package) which itself builds from the initscripts SRPM. I guess there are people still using it, so I will switch the requirement.

Comment 2 David Kaspar [Dee'Kej] 2018-06-20 12:41:13 UTC
(In reply to Jaroslav Škarvada from comment #1)
> It's for '/etc/sysconfig/network-scripts', it seems this directory is in f29
> provided by the network-scripts package (previously it has been provided by
> the initscripts package) which itself builds from the initscripts SRPM. I
> guess there are people still using it, so I will switch the requirement.

Yes, for the 'ppp' we can't drop the requirements yet, and switching it to 'network-scripts' should be enough... ;) Thanks!