Bug 1593000

Summary: [Rebase]: update to nfs-ganesha 2.7
Product: Red Hat Ceph Storage Reporter: tserlin
Component: DistributionAssignee: tserlin
Status: CLOSED ERRATA QA Contact: Sidhant Agrawal <sagrawal>
Severity: medium Docs Contact: Bara Ancincova <bancinco>
Priority: high    
Version: 3.2CC: anharris, dang, hnallurv, kdreyer, pasik, rgowdege, vakulkar
Target Milestone: rcKeywords: Rebase
Target Release: 3.2   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: RHEL: nfs-ganesha-2.7.1-1.el7cp Ubuntu: nfs-ganesha_2.7.1-5redhat1xenial Doc Type: Enhancement
Doc Text:
.`nfs-ganesha` rebased to 2.7 The `nfs-ganesha` package has been upgraded to upstream version 2.7, which provides a number of bug fixes and enhancements over the previous version.
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-01-03 19:01:22 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1566082, 1629656    

Comment 4 Daniel Gryniewicz 2018-06-20 12:33:26 UTC
The admin_thread one is too new to be in 2.6.2, it was merged later that week. It will presumably be in the next 2.6 merge.  As for the others, I'm not sure why they weren't taken. We took another RADOS_KV change from that same merge window.   The last 3 aren't actually functional changes, just code re-org and debug messages, so they aren't very important (except for making other backports easier).  But the "fix append" one is an actual bug fix and should probably be taken.

Comment 14 errata-xmlrpc 2019-01-03 19:01:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020