Bug 1595083

Summary: go-hdb unsupported on s390x
Product: [Fedora] Fedora Reporter: Ed Marshall <esm>
Component: golang-github-SAP-go-hdbAssignee: Ed Marshall <esm>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 29CC: esm, zebob.m
Target Milestone: ---   
Target Release: ---   
Hardware: s390x   
OS: Unspecified   
Whiteboard:
Fixed In Version: golang-github-SAP-go-hdb-0.14.0-1.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-03-14 15:06:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 485231    

Description Ed Marshall 2018-06-26 04:52:51 UTC
Upstream limits support to "known architectures" because endianness matters for them:

https://github.com/SAP/go-hdb/issues/23

Comment 1 Jan Kurik 2018-08-14 11:05:56 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 2 Robert-André Mauchin 2019-03-14 15:06:33 UTC
Fixed in golang-github-SAP-go-hdb-0.14.0-1.fc29.