Bug 1596190

Summary: Binutils 2.31
Product: [Fedora] Fedora Reporter: Jan Kurik <jkurik>
Component: Changes TrackingAssignee: Nick Clifton <nickc>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 29CC: awilliam, bcotton, nickc
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: ChangeAcceptedF29,SystemWideChange
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-11-30 17:04:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jan Kurik 2018-06-28 12:05:12 UTC
This is a tracking bug for Change: Binutils 2.31
For more details, see: https://fedoraproject.org/wiki/Changes/BINUTILS231

Rebase the binutils package from version 2.30 to version 2.31.

Comment 1 Adam Williamson 2018-08-07 17:38:45 UTC
This is clearly 'testable' right now as we've had 2.31 in Rawhide since 2018-07-19, setting to MODIFIED. Note the mass rebuild was done with a 2.31 candidate, 2.30.90, per https://pagure.io/releng/issue/7480 - from the discussion there it seems like this was agreed by the binutils devs, so this should be OK.

Comment 2 Jan Kurik 2018-08-14 11:17:52 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 3 Ben Cotton 2018-08-28 13:54:00 UTC
Today is the '100% code complete deadline' Change Checkpoint[1], meaning that Fedora 29 Changes must now be code complete. All the code required to enable to the new change should now be finished. If your Change is code complete, please update the status of this tracker back to "ON_QA". The change does not have to be fully tested by this deadline.

We have now reached the Beta freeze. If your Change is not code complete, you need to request a Freeze Exception[2] or invoke the contingency plan.

[1] https://fedoraproject.org/wiki/Changes/Policy#Beta_deadline.2Faccepted_changes_100.25_complete

[2] https://fedoraproject.org/wiki/QA:SOP_freeze_exception_bug_process

Comment 4 Nick Clifton 2018-08-28 14:42:00 UTC
The change is code complete.  There is no need for a freeze exception.

Comment 5 Ben Cotton 2018-08-29 18:15:45 UTC
Marking ON_QA since change is code complete.

Comment 6 Ben Cotton 2018-11-30 17:04:37 UTC
This Change appears to have been implemented for Fedora 29. If it is not closed, please let me know so I can re-open it against Rawhide.