Bug 1601741

Summary: [ja] "dnf updateinfo info" not formatted well in Japanese
Product: [Fedora] Fedora Reporter: Jens Petersen <petersen>
Component: dnfAssignee: Daniel Mach <dmach>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: dmach, mblaha, packaging-team-maint, rpm-software-management, vmukhame
Target Milestone: ---Keywords: i18n, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: dnf-4.2.11-2.fc30 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-10-10 16:55:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
screenshot in gnome-terminal none

Description Jens Petersen 2018-07-17 07:30:07 UTC
Created attachment 1459320 [details]
screenshot in gnome-terminal

Description of problem:
In Japanese locale at least the output of "dnf updateinfo info"
is not formatted well I guess this is due to not taking wide characters
into account.

How reproducible:
100%

Steps to Reproduce:
1. LANG=ja_JP.utf8 sudo dnf updateinfo info

Actual results:
eg:

```
===============================================================================
  dracut-048-1.fc28
===============================================================================
Update ID : FEDORA-2018-357becc8f1
     Type : バグ修正
       更新 : 2018-07-17 00:51:28
       説明 : dracut:
          : 
          : - fixed finding of btrfs devices
          : - harden dracut against BASH_ENV environment variable

```

Expected results:
Consistent alignment of colons

Additional info:
I think it been like this for a quite a long time (forever?)
but the alignment is not good and makes it harder to read/parse.

Comment 1 Parag Nemade 2019-03-26 06:49:56 UTC
Present in F30

Comment 3 Fedora Update System 2019-10-02 08:31:54 UTC
FEDORA-2019-049b4836a6 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-049b4836a6

Comment 4 Fedora Update System 2019-10-03 01:52:33 UTC
dnf-4.2.11-2.fc30, dnf-plugins-core-4.0.10-1.fc30, libdnf-0.35.5-2.fc30, librepo-1.10.6-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-049b4836a6

Comment 5 Fedora Update System 2019-10-10 16:55:58 UTC
dnf-4.2.11-2.fc30, dnf-plugins-core-4.0.10-1.fc30, libdnf-0.35.5-2.fc30, librepo-1.10.6-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.