Bug 1603031

Summary: A custom button doesn't work on a service which has no parent catalog item associated with it.
Product: Red Hat CloudForms Management Engine Reporter: Satoe Imaishi <simaishi>
Component: AutomateAssignee: drew uhlmann <duhlmann>
Status: CLOSED ERRATA QA Contact: Nikhil Dhandre <ndhandre>
Severity: medium Docs Contact:
Priority: high    
Version: 5.9.0CC: ccoupel, cpelland, dajohnso, duhlmann, gmccullo, jprause, mkanoor, ngupta, obarenbo, smallamp, tfitzger
Target Milestone: GAKeywords: Regression, Reopened, ZStream
Target Release: 5.9.4   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 5.9.4.1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1595051 Environment:
Last Closed: 2018-09-04 18:01:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core
Bug Depends On: 1595051    
Bug Blocks:    

Comment 3 CFME Bot 2018-07-19 09:15:46 UTC
New commit detected on ManageIQ/manageiq/gaprindashvili:

https://github.com/ManageIQ/manageiq/commit/0378482d9f90600e3614cf65573b87f372bf04c2
commit 0378482d9f90600e3614cf65573b87f372bf04c2
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Tue Jul 17 19:01:41 2018 -0400
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Tue Jul 17 19:01:41 2018 -0400

    Merge pull request #17703 from d-m-u/bz1595051

    Return custom buttons for service having nil service template
    (cherry picked from commit 2d8f3e83bcc4e9ea519596957e99d9e69baf5041)

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1603031

 app/models/service.rb | 7 +-
 spec/models/service_spec.rb | 35 +-
 2 files changed, 32 insertions(+), 10 deletions(-)

Comment 6 errata-xmlrpc 2018-09-04 18:01:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2018:2561