Bug 160362

Summary: Firmware doesn't get loaded with udevsend
Product: [Fedora] Fedora Reporter: Bart Vanbrabant <bart.vanbrabant>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: notting
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://forums.divx.com/eve/ubb.x/a/tpc/f/996105602/m/820108152
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-15 08:22:28 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Bart Vanbrabant 2005-06-14 14:54:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; nl-NL; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
At the start of may /proc/sys/kernel/hotplug changed from /sbin/hotplug to /sbin/udevsend in rawhide.
Due to this change the firmware for my Plextor ConvertX tv-tuner isn't loaded anymore. It uses hotplug and fxload. By changing the proc entry this is fixed.

In this forum thread the developer of the driver pointed me to the solution:
http://forums.divx.com/eve/ubb.x/a/tpc/f/996105602/m/820108152

The driver (open source) can be found here:
http://www.plextor.com/english/support/LinuxSDK.htm

To reproduce this particular problem this hardware is needed. But the problem is that the hotplug script needed to load the usb firmware isn't called anymore.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Load the kernel modules
2. Plugin the hardware
3.
  

Additional info:
Comment 1 Bill Nottingham 2005-06-14 17:51:37 EDT
udevsend is still supposed to call the various hotplug agents, such as the
firmware agent.
Comment 2 Harald Hoyer 2005-06-15 04:32:30 EDT
could you set 
DEBUG=yes
in
/etc/sysconfig/hotplug

and turn on logging in /etc/udev.conf to debug the problem?
Comment 3 Bart Vanbrabant 2005-06-15 05:34:33 EDT
For some very strange reason it works now. I turned the debug things of and
rebooted and it still works. 
I had been using a script that changes the proc entry and loads the kernel
modules for a month now. I also regulary tested if it worked in the normal way.
Now it seems to work and I can't reproduce the old behaviour anymore.

If it turns up again I'll try to get a debug log.
Comment 4 Steve Parker 2005-09-02 16:36:15 EDT
I am also having this problem with an HP Laserjet 1000 printer.  It works fine
if I manually load the firmware but udevsend will not load it.  I was going to
follow the debugging steps above but I have neither /etc/sysconfig/hotplug nor
/etc/udev.conf.  Should these already exist or am I creating them new??
Comment 5 Steve Parker 2005-09-02 16:51:38 EDT
My apologies for not doing a little research first.  I found udev.conf (it's at
the err logging level currently) and created /etc/sysconfig/hotplug myself. 
Here are the results:

Turn on the printer:

Sep  2 16:49:21 localhost kernel: usb 1-2: new full speed USB device using
uhci_hcd and address 12
Sep  2 16:49:22 localhost kernel: drivers/usb/class/usblp.c: usblp0: USB
Bidirectional printer dev 12 if 0 alt 0 proto 2 vid 0x03F0 pid 0x0517
Sep  2 16:49:22 localhost default.hotplug[2840]: arguments (usb) env
(SUBSYSTEM=usb OLDPWD=/ DEVPATH=/devices/pci0000:00/0000:00:1f.2/usb1/1-2
PATH=/bin:/sbin:/usr/sbin:/usr/bin ACTION=add PWD=/etc/hotplug UDEV_LOG=3
MANAGED_EVENT=1 UDEVD_EVENT=1 SHLVL=1 HOME=/ PHYSDEVDRIVER=usb PHYSDEVBUS=usb
SEQNUM=487 _=/bin/env)
Sep  2 16:49:22 localhost default.hotplug[2840]: invoke /etc/hotplug/usb.agent ()
Sep  2 16:49:22 localhost default.hotplug[2849]: arguments (usb) env
(SUBSYSTEM=usb OLDPWD=/
DEVPATH=/devices/pci0000:00/0000:00:1f.2/usb1/1-2/1-2:1.0
PATH=/bin:/sbin:/usr/sbin:/usr/bin ACTION=add
MODALIAS=usb:v03F0p0517d0120dc00dsc00dp00ic07isc01ip02 PWD=/etc/hotplug
UDEV_LOG=3 MANAGED_EVENT=1 UDEVD_EVENT=1 SHLVL=1 HOME=/
DEVICE=/proc/bus/usb/001/012 INTERFACE=7/1/2 PRODUCT=3f0/517/120 TYPE=0/0/0
PHYSDEVBUS=usb SEQNUM=488 _=/bin/env)
Sep  2 16:49:22 localhost default.hotplug[2849]: invoke /etc/hotplug/usb.agent ()
Sep  2 16:49:23 localhost usb.agent[2849]: Setup usblp for USB product 3f0/517/120
Sep  2 16:49:23 localhost usb.agent[2849]: Setup hplj1000 for USB product
3f0/517/120
Sep  2 16:49:23 localhost usb.agent[2849]: Module setup hplj1000 for USB product
3f0/517/120
Sep  2 16:49:23 localhost default.hotplug[2898]: arguments (usb) env
(PHYSDEVPATH=/devices/pci0000:00/0000:00:1f.2/usb1/1-2/1-2:1.0 SUBSYSTEM=usb
OLDPWD=/ DEVPATH=/class/usb/lp0 MINOR=0 PATH=/bin:/sbin:/usr/sbin:/usr/bin
ACTION=add PWD=/etc/hotplug UDEV_LOG=3 MAJOR=180 MANAGED_EVENT=1 UDEVD_EVENT=1
DEVNAME=/dev/usb/lp0 SHLVL=1 HOME=/ PHYSDEVDRIVER=usblp PHYSDEVBUS=usb
SEQNUM=489 _=/bin/env)
Sep  2 16:49:23 localhost default.hotplug[2898]: invoke /etc/hotplug/usb.agent ()

Turn off the printer:

Sep  2 16:51:19 localhost kernel: usb 1-2: USB disconnect, address 12
Sep  2 16:51:19 localhost kernel: drivers/usb/class/usblp.c: usblp0: removed
Sep  2 16:51:20 localhost default.hotplug[2916]: arguments (usb) env
(PHYSDEVPATH=/devices/pci0000:00/0000:00:1f.2/usb1/1-2/1-2:1.0 SUBSYSTEM=usb
OLDPWD=/ DEVPATH=/class/usb/lp0 MINOR=0 PATH=/bin:/sbin:/usr/sbin:/usr/bin
ACTION=remove PWD=/etc/hotplug UDEV_LOG=3 MAJOR=180 MANAGED_EVENT=1
UDEVD_EVENT=1 DEVNAME=/dev/usb/lp0 SHLVL=1 HOME=/ PHYSDEVDRIVER=usblp
PHYSDEVBUS=usb SEQNUM=490 _=/bin/env)
Sep  2 16:51:20 localhost default.hotplug[2916]: invoke /etc/hotplug/usb.agent ()
Sep  2 16:51:20 localhost default.hotplug[2924]: arguments (usb) env
(SUBSYSTEM=usb OLDPWD=/
DEVPATH=/devices/pci0000:00/0000:00:1f.2/usb1/1-2/1-2:1.0
PATH=/bin:/sbin:/usr/sbin:/usr/bin ACTION=remove
MODALIAS=usb:v03F0p0517d0120dc00dsc00dp00ic07isc01ip02 PWD=/etc/hotplug
UDEV_LOG=3 MANAGED_EVENT=1 UDEVD_EVENT=1 SHLVL=1 HOME=/
DEVICE=/proc/bus/usb/001/012 INTERFACE=7/1/2 PRODUCT=3f0/517/120 TYPE=0/0/0
PHYSDEVBUS=usb SEQNUM=491 _=/bin/env)
Sep  2 16:51:20 localhost default.hotplug[2924]: invoke /etc/hotplug/usb.agent ()
Sep  2 16:51:20 localhost default.hotplug[2937]: arguments (usb) env
(SUBSYSTEM=usb OLDPWD=/ DEVPATH=/devices/pci0000:00/0000:00:1f.2/usb1/1-2
PATH=/bin:/sbin:/usr/sbin:/usr/bin ACTION=remove PWD=/etc/hotplug UDEV_LOG=3
MANAGED_EVENT=1 UDEVD_EVENT=1 SHLVL=1 HOME=/ PHYSDEVBUS=usb SEQNUM=492 _=/bin/env)
Sep  2 16:51:20 localhost default.hotplug[2937]: invoke /etc/hotplug/usb.agent ()

Please advise if more info is required.  Thanks.
Comment 6 Bill Nottingham 2005-09-02 17:26:26 EDT
That doesn't use the standard firmware agent; you'd need a udev rule to load the
firmware.