Bug 160512

Summary: nfs client hangs when mounting/unmouting repeatedly the same disk
Product: [Fedora] Fedora Reporter: Dimitri Papadopoulos <dimitri.papadopoulos>
Component: nfs-utilsAssignee: Steve Dickson <steved>
Status: CLOSED DUPLICATE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: 4   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-06-15 11:50:25 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Dimitri Papadopoulos 2005-06-15 11:14:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Mounting/unmounting the same remote directory repeatedly hangs the client:

# mount -t nfs pelles:/outils/linux/local /usr/local
# mount | fgrep pelles
pelles:/outils/linux/local on /usr/local type nfs (rw,addr=172.16.4.204)
# umount /usr/local
# 
# mount -t nfs pelles:/outils/linux/local /usr/local
# mount | fgrep pelles
pelles:/outils/linux/local on /usr/local type nfs (rw,addr=172.16.4.204)
# umount /usr/local
# 
# mount -t nfs pelles:/outils/linux/local /usr/local
[***hangs here for a few minutes***]
mount: pelles:/outils/linux/local: can't read superblock
# mount | fgrep pelles
#
# mount -t nfs pelles:/outils/linux/local /usr/local
# mount | fgrep pelles
pelles:/outils/linux/local on /usr/local type nfs (rw,addr=172.16.4.204)
# umount /usr/local
# 

The NFS server is running IRIX:
$ uname -aR
IRIX64 pelles 6.5 6.5.23f 01080747 IP27
$ 

I cannot reproduce the client hanging with a Solaris 8 NFS server:
$ uname -a
SunOS uriens 5.8 Generic_108528-22 sun4u sparc SUNW,Sun-Fire-480R
$ 

This could be a problem with IRIX, but on the other hand we have been running Red Hat 9, Fedora Core 2, and Solaris 8 client workstations without such problems for years.


Version-Release number of selected component (if applicable):
nfs-utils-1.0.7-8

How reproducible:
Sometimes

Steps to Reproduce:
1.dsfsd
  

Additional info:
Comment 1 Dimitri Papadopoulos 2005-06-15 11:50:25 EDT

*** This bug has been marked as a duplicate of 160514 ***