Bug 1605739

Summary: python-keystonemiddleware: FTBFS in Fedora rawhide
Product: [Fedora] Fedora Reporter: Mohan Boddu <mboddu>
Component: python-keystonemiddlewareAssignee: Alan Pevec <apevec>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: urgent    
Version: 29CC: apevec, awilliam, fzatlouk, hguemar, jruzicka, mhroncok, nkinder
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: python-keystonemiddleware-4.21.0-1.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-09-11 12:43:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1602938, 1517012, 1565020    
Attachments:
Description Flags
build.log
none
root.log
none
state.log none

Description Mohan Boddu 2018-07-20 16:45:43 UTC
python-keystonemiddleware failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28222512


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix python-keystonemiddleware at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
python-keystonemiddleware will be orphaned. Before branching of Fedora 30,
python-keystonemiddleware will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 16:45:54 UTC
Created attachment 1466332 [details]
build.log

Comment 2 Mohan Boddu 2018-07-20 16:45:59 UTC
Created attachment 1466333 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 16:46:03 UTC
Created attachment 1466334 [details]
state.log

Comment 4 Miro Hrončok 2018-07-25 09:26:51 UTC
(This is a mass bug update. Forgive me if things are not 100% accurate for this one.)

At this moment, your package still requires Python 3.6. This will cause broken upgrades to Fedora 29. Please prioritize this rebuild.

Let me know if you need help from the Python maintenance team figuring out why the package FTBFS.

Consider orphaning the package if you don't have time for it.

Consider retiring the package if upstream is dead and nothing depends on it in Fedora.

If you are blocked by other packages (I've recently tried to set the Bugzilla metadata to reflect that), consider helping there as well. Thank you.

Comment 5 Miro Hrončok 2018-08-06 10:22:36 UTC
This is another friendly reminder.

Please take action.

Comment 6 Miro Hrončok 2018-08-10 13:47:35 UTC
Note that I requested an approval from FESCo to retire leaf packages that still require Python 3.6 at beta freeze and their bugs are in NEW state. (This package might not necessarily be leaf at this moment, but I'm updating all the bugs in case the dependencies change in the meantime.)

More info at https://pagure.io/fesco/issue/1965

Comment 7 Miro Hrončok 2018-08-13 11:59:48 UTC
Another bulk reminder. Please take action. Your package doesn't install on Fedora 29. Fix it or retire it.

Comment 8 Jan Kurik 2018-08-14 10:28:22 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 9 Miro Hrončok 2018-08-16 12:31:13 UTC
Do something now! (This is the unfriendly reminder.)

Comment 10 Miro Hrončok 2018-08-16 15:13:59 UTC
I apologize if my unfriendly reminder was too harsh. It was intended to be stronger than the previous friendly reminders, not to hurt anyone.

That said, this still needs to be taken care of.

Comment 11 Miro Hrončok 2018-08-17 11:49:41 UTC
Leaf packages that still require Python 3.6 one week before Fedora 29 Beta Freeze ([0]) and their FTBFS bug remains in NEW state, will be mass retired. Packages marked as blocked by non-FTBFS bug are excluded from this. [1]

[0] https://fedoraproject.org/wiki/Releases/29/Schedule
[1] https://pagure.io/fesco/issue/1965

Comment 12 Miro Hrončok 2018-08-20 13:59:32 UTC
Note that beta freeze is scheduled for 2018-08-28 so the deadline is tomorrow. You don't need to fix this by tomorrow, a change of state of this bug that indicates you will work on this (e.g. to ASSIGNED) is OK as well.

Comment 13 hguemar 2018-08-20 21:16:13 UTC
Alan is in vacation, so taking over.

Comment 14 hguemar 2018-08-23 15:09:10 UTC
Fixed in rawhide/F29

Comment 15 Miro Hrončok 2018-08-28 12:48:44 UTC
Only built in f30.

Comment 16 Fedora Blocker Bugs Application 2018-08-30 11:59:47 UTC
Proposed as a Freeze Exception for 29-beta by Fedora user churchyard using the blocker tracking app because:

 Having the package installed blocks upgrade to Fedora 29.

Comment 17 Fedora Update System 2018-08-30 12:05:12 UTC
python-keystonemiddleware-4.21.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a2754759c6

Comment 18 Fedora Update System 2018-08-30 15:01:33 UTC
python-keystonemiddleware-4.21.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a2754759c6

Comment 19 František Zatloukal 2018-09-04 10:07:06 UTC
Package is building fine, marking as VERIFIED.

Comment 20 Adam Williamson 2018-09-10 23:28:11 UTC
Discussed at 2018-09-10 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-09-10/f29-blocker-review.2018-09-10-16.01.html . Accepted (under the block vote at the end of the meeting) as a freeze exception issue as this can prevent upgrades working without the potentially-dangerous --allowerasing , and upgrades typically run without updates-testing so there is a benefit to pushing this stable for folks trying to upgrade at present.

Comment 21 Fedora Update System 2018-09-11 12:43:25 UTC
python-keystonemiddleware-4.21.0-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.