Bug 160828

Summary: Non-GPG key confuses up2date and yum
Product: [Fedora] Fedora Reporter: Michael Tiemann <tiemann>
Component: evinceAssignee: Marco Pesenti Gritti <mpg>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: jpmahowald
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-29 21:25:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michael Tiemann 2005-06-17 18:01:58 UTC
Description of problem:

The evince package is not signed with a GPG key.  up2date simply aborts because
there is no such key, and yum flags it and asks whether to proceed or not.

Version-Release number of selected component (if applicable):

evince-0.3.1-1.i386.rpm

How reproducible:

On an fc4 system that does not have evince installed, try to use up2date

Steps to Reproduce:
1. rpm -e evince
2. up2date evince

Actual results:

evince-0.3.1-1.i386.rpm:    ########################## Done.
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID
4f2a6fd2
The package evince-0.3.1-1 is not signed with a GPG signature.
Aborting...
Package evince-0.3.1-1 does not have a GPG signature.
 Aborting...

Expected results:


Additional info: