Bug 161157

Summary: tg3 module fails to work on kickstart process, this happens on rhas3
Product: Red Hat Enterprise Linux 3 Reporter: its-systems <its-systems>
Component: kernelAssignee: John W. Linville <linville>
Status: CLOSED CANTFIX QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 3.0CC: davem, petrides
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-09-16 10:24:08 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description its-systems 2005-06-20 17:05:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
Attempting to kickstart Dell 2650 servers, the kickstart process cannot get a IP from DHCP, attempted a manual IP also failed. Kickstart process works for Dell 2850 and NFS mounts work so the rest of the process is fine.

Version-Release number of selected component (if applicable):
original rhas3 and update 5

How reproducible:
Always

Steps to Reproduce:
1. #network module load for a 2650
device net tg3
device net e1000

2. Burn CD, try a kickstart install.
3. Standard install seems OK, but this means 12 seperate manual installs...with no disaster recovery so is really not wanted.
  

Actual Results:  Says cannot mount at 130.195.20.239 /redhat/rhas3-5

Expected Results:  Mount should happen and kickstart completes, this works for Dell 1850s, 2850s (-64 arch), Dell 2300s (x86) and various Fedora test beds. Most units use the e100 or e1000 so this suggests a problem with the tg3 module.

Additional info:

Dell 2650
Comment 1 John W. Linville 2005-06-21 15:04:01 EDT
Have you tried booting the 2650 w/ either "noapic", "acpi=noirq" or 
"acpi=off"?  Please try all three and post the results...thanks! 
Comment 2 John W. Linville 2005-07-06 15:39:40 EDT
Please do provide the requested information...additionally, test kernels w/ 
newest tg3 driver available here: 
 
   http://people.redhat.com/linville/kernels/rhel3/ 
 
Although you will not be able to install using them, it may be worth seeing if 
they get you farther along the process.  Please post your results...thanks! 
Comment 3 John W. Linville 2005-09-16 10:24:08 EDT
Closing due to lack of response.  Please re-open when requested information 
becomes available...thanks!