Bug 1623463

Summary: [FFU] Gnocchi-statsd container reported unhealthy after FFU.
Product: Red Hat OpenStack Reporter: Leonid Natapov <lnatapov>
Component: openstack-tripleo-commonAssignee: Adriano Petrich <apetrich>
Status: CLOSED CURRENTRELEASE QA Contact: Leonid Natapov <lnatapov>
Severity: medium Docs Contact:
Priority: high    
Version: 13.0 (Queens)CC: apannu, apetrich, lmarsh, mburns, mmagr, pkilambi, rcernin, rmeillon, slinaber
Target Milestone: z3Keywords: TestOnly, Triaged, ZStream
Target Release: 13.0 (Queens)Flags: apetrich: needinfo-
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-common-8.6.6-2.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-11-15 11:42:34 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Leonid Natapov 2018-08-29 12:26:40 UTC
After FFU gnocchi-statsd container reported unhealthy.

/gnocchi_statsd (1aeb99dd5530): There is no gnocchi-statsd process with opened Redis ports (6379) running in the container ;

Happens because we should be checking connection to statsd port not redis.

Comment 2 Martin Magr 2018-09-10 15:04:37 UTC
Patch for this is already in upstream. Will check, why we don't have it in downstream.

Comment 4 Martin Magr 2018-09-10 15:19:00 UTC
Ok, we need to backport this to 13.

Comment 12 Leonid Natapov 2018-11-14 14:36:12 UTC
8494cd66cee2        192.168.24.1:8787/rhosp13/openstack-gnocchi-statsd:2018-11-05.3              "kolla_start"            16 hours ago        Up 16 hours (healthy)                             gnocchi_statsd

openstack-tripleo-common-8.6.6-2.el7ost.noarch

Comment 13 Lon Hohberger 2018-11-15 11:42:34 UTC
According to our records, this should be resolved by openstack-tripleo-common-8.6.6-2.el7ost.  This build is available now.