Bug 1623860

Summary: Octavia python 3.6 support
Product: Red Hat OpenStack Reporter: Bernard Cafarelli <bcafarel>
Component: openstack-octaviaAssignee: Nir Magnezi <nmagnezi>
Status: CLOSED ERRATA QA Contact: Bruna Bonguardo <bbonguar>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 15.0 (Stein)CC: amuller, cgoncalves, ihrachys, lpeer, majopela, tfreger
Target Milestone: Upstream M3Keywords: FutureFeature, Triaged
Target Release: 15.0 (Stein)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-octavia-4.0.2-0.20190618180410.0598806.el8ost Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-21 11:18:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bernard Cafarelli 2018-08-30 10:45:08 UTC
OpenStack is moving to run under Python 3 by default in community goal:
https://governance.openstack.org/tc/goals/stein/python3-first.html

Octavia should support running under python 3.6, initial identified steps include:
* Switch upstream gates to py3
* Downstream CI python3-based
* RPM packaging
* Local testing (tempest runs, …) with Fedora 28 system

Comment 9 errata-xmlrpc 2019-09-21 11:18:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811