Bug 1624337

Summary: [GV100GL] second monitor won't lid
Product: Red Hat Enterprise Linux 7 Reporter: Tomas Pelka <tpelka>
Component: xorg-x11-drv-nouveauAssignee: Ben Skeggs <bskeggs>
Status: CLOSED WONTFIX QA Contact: Desktop QE <desktop-qa-list>
Severity: unspecified Docs Contact: Marek Suchánek <msuchane>
Priority: unspecified    
Version: 7.6CC: bskeggs, riehecky, tpelka
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Known Issue
Doc Text:
GV100GL graphics cannot use correctly more than one monitor Due to missing signed firmware for the GV100GL graphics, GV100GL cannot have more than one monitor connected. When a second monitor is connected, it is recognized, and graphics set the correct resolution, but the monitor stays in power-saving mode. To work around this problem, install the *NVIDIA* binary driver. As a result, the second monitor output works as expected under the described circumstances.
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-02-15 07:42:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1457161    
Attachments:
Description Flags
when second monitor is connected none

Description Tomas Pelka 2018-08-31 09:10:19 UTC
Created attachment 1480051 [details]
when second monitor is connected

Description of problem:
it is recognized, graphics set the correct resolution but monitor stay in power saving mode

Version-Release number of selected component (if applicable):
kernel-3.10.0-940.el7.x86_64
xorg-x11-drv-nouveau-1.0.15-1.el7.x86_64
xorg-x11-server-Xorg-1.20.1-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
see attachement

Expected results:
`

Additional info:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GV100GL [Quadro GV100] [10de:1dba] (rev a1)

I tried different monitor with the same resolution but still the same

Comment 2 Tomas Pelka 2018-08-31 10:08:26 UTC
I basically can see the same messages when booting with no screen attached and than plug just one monitor in. The result is the same, so black screens or rather  monitoring just reporting it is switching to powersave mode but xrandre seems to be happy:

DP-4 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080     60.00*+  59.96    50.00    59.94    59.93  
   1920x1200     59.95  
   1600x1200     65.00    60.00  
   1680x1050     59.95    59.88  
   1400x1050     74.76    59.98  
   1600x900      59.95    59.82  
   1280x1024     75.02    60.02  
   1440x900      74.98    59.90  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      59.97  
   1368x768      59.88    59.85  
   1280x800      59.99    59.97    59.81    59.91  
   1152x864      75.00  
   1280x720      60.00    59.99    59.86    60.00    50.00    59.94    59.74  
   1024x768      75.05    60.04    75.03    70.07    60.00  
   960x720       75.00    60.00  
   928x696       75.00    60.05  
   896x672       75.05    60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   832x624       74.55  
   960x540       59.96    59.99    59.63    59.82  
   800x600       75.00    70.00    65.00    60.00    72.19    75.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   720x576       50.00  
   700x525       74.76    59.98  
   800x450       59.95    59.82  
   720x480       60.00    59.94  
   640x512       75.02    60.02  
   700x450       59.96    59.88  
   640x480       60.00    75.00    72.81    75.00    66.67    60.00    59.94  
   720x405       59.51    58.99  
   720x400       70.08  
   684x384       59.88    59.85  
   640x400       59.88    59.98  
   576x432       75.00  
   640x360       59.86    59.83    59.84    59.32  
   512x384       75.03    70.07    60.00  
   512x288       60.00    59.92  
   416x312       74.66  
   480x270       59.63    59.82  
   400x300       72.19    75.12    60.32    56.34  
   432x243       59.92    59.57  
   320x240       72.81    75.00    60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32

Comment 3 Adam Kvitek 2018-09-21 15:09:36 UTC
Hello Ben,

could you please provide me with information about this known issue and fill it in the Doc Text field? If this bug does not have to be documented, please write it in a comment.

If you need a reference for filling up the Doc Text field, use this:

--

Cause

What actions or circumstances cause the bug to present (if known). Note that if the cause is not known or is not fully diagnosed, current hypotheses or theories should be noted.

Consequence

What happens when the bug presents. 

Workaround

What actions, if any, reduce the bug’s effects or prevent it from presenting entirely.

Result

If the bug’s effect is only reduced, what consequences still follow; if the bug is prevented, what restrictions does the workaround impose. 

--

If you have any other questions, please contact me.

Best regards,
Adam Kvítek

Comment 7 Marie Hornickova 2018-10-19 07:39:46 UTC
Hi Tomas,

This bug is on the list of candidates to be documented for RHEL 7.6 Release Notes.

Please, could you provide initial info in CCWR structure (cause, consequence, workaround, result) to document this bug?

Thank you!

Marie

Comment 8 Tomas Pelka 2018-10-19 08:05:48 UTC
Well this is a consequence of Bug 1457161, due to missing signed firmware for this particular graphics it can operate only using just single monitor output. The workaround is installing/build nvidia binary driver.

Comment 16 RHEL Program Management 2021-02-15 07:42:13 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.