Bug 1626076

Summary: Raspberry Pi fixes and improvements for IoT
Product: [Fedora] Fedora Reporter: Peter Robinson <pbrobinson>
Component: bcm283x-firmwareAssignee: Peter Robinson <pbrobinson>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 29CC: awilliam, bugzilla, labbott, pbrobinson, pwhalen
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: bcm283x-firmware-20180829-3.ec3f856.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-10-06 16:19:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 245418, 1269538, 1517012    

Description Peter Robinson 2018-09-06 14:13:45 UTC
This provides a number of fixes for Raspberry Pi particularly targeted at IoT but also affects ARM (ARMv7 and aarch64).

It covers a PR for kickstarts: https://pagure.io/fedora-kickstarts/pull-request/423

And the following update: https://bodhi.fedoraproject.org/updates/FEDORA-2018-56bc88dfb2

The changes have been in rawhide for a week, and it's been pretty well tested in other arenas.

It also, but it's a minor component, assists the UEFI on ARMv7 feature and it would be good to land this before beta because it will assist in upgrade and migration process for this as well.

Comment 1 Fedora Update System 2018-09-06 14:14:29 UTC
arm-trusted-firmware-1.5-4.20180830.fc29 bcm283x-firmware-20180829-3.ec3f856.fc29 uboot-tools-2018.09-0.4.rc3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-56bc88dfb2

Comment 2 Fedora Blocker Bugs Application 2018-09-06 14:16:42 UTC
Proposed as a Freeze Exception for 29-beta by Fedora user pbrobinson using the blocker tracking app because:

 This is a little on the fence for Blocker or FE. It covers a number of bugs across a number of ARM platforms.

The main reason for FE is it's a IoT requirement for a key IoT devices the Raspberry Pi, as well as number of aarch64 devices use for IoT.

Finally it's a component of UEFI on ARMv7

Comment 3 Fedora Update System 2018-09-07 06:00:05 UTC
arm-trusted-firmware-1.5-4.20180830.fc29, bcm283x-firmware-20180829-3.ec3f856.fc29, uboot-tools-2018.09-0.4.rc3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-56bc88dfb2

Comment 4 Chris Murphy 2018-09-08 21:31:00 UTC
+1 beta freeze exception

Comment 5 Adam Williamson 2018-09-10 22:40:48 UTC
Discussed at 2018-09-10 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-09-10/f29-blocker-review.2018-09-10-16.01.html . Accepted as a freeze exception issue: these fixes are desirable for Beta and cannot be fully applied as updates.

Comment 6 Fedora Update System 2018-09-11 12:44:33 UTC
arm-trusted-firmware-1.5-4.20180830.fc29, bcm283x-firmware-20180829-3.ec3f856.fc29, uboot-tools-2018.09-0.4.rc3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Adam Williamson 2018-09-12 19:25:44 UTC
Apparently the kickstarts PR was not yet merged, so this is not complete.

Some noise was made about doing an RC2 for this, but by policy we do not respin only for FEs. We respin only for blockers.

Does this in fact prevent any release-blocking ARM image from booting/working correctly on any release-blocking ARM platform? IoT stuff is, AIUI, not (yet) release blocking.

Comment 8 Adam Williamson 2018-09-12 19:26:25 UTC
edit: the PR is merged now, but was not included in Beta-1.1 (RC1).

Comment 9 Peter Robinson 2018-09-12 20:19:32 UTC
To answer the need info: the changes broke all armhfp (ARMv7/arm32) because the kickstart change wasn't merged at the same time as the packages went stable which meant the RPi firmware wasn't in the right location and hence the raspberry pi won't boot on any 32 bit images including blockers.