Bug 1629532 (CVE-2018-11780)

Summary: CVE-2018-11780 spamassassin: Potential remote code execution vulnerability in PDFInfo plugin
Product: [Other] Security Response Reporter: Sam Fowler <sfowler>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: unspecifiedCC: jjelen, jskarvad, kevin, nb, olysonek, wtogami
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: impact=important,public=20180917,reported=20180917,source=internet,cvss3=8.1/CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H,cwe=CWE-400,fedora-all/spamassassin=affected,rhel-5/spamassassin=notaffected,rhel-6/spamassassin=notaffected,rhel-7/spamassassin=notaffected,rhel-8/spamassassin=notaffected
Fixed In Version: spamassassin 3.4.2 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-10-12 03:27:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1629534, 1629535    
Bug Blocks: 1629527    

Description Sam Fowler 2018-09-17 03:22:40 UTC
Apache SpamAssassin before version 3.4.2 is vulnerable to a potential remote code execution vulnerability in the PDFInfo plugin.


External Reference:

https://mail-archives.apache.org/mod_mbox/spamassassin-announce/201809.mbox/raw/%3Cc57c0f41-742c-3c3e-249c-ae2614bf0d7d%40apache.org%3E/

Comment 1 Sam Fowler 2018-09-17 03:23:04 UTC
Created spamassassin tracking bugs for this issue:

Affects: fedora-all [bug 1629534]

Comment 7 Huzaifa S. Sidhpurwala 2018-09-24 10:07:51 UTC
The affected PDF plugin is not shipped with the versions of SpamAssassin shipped with Red Hat Enterprise Linux 5, 6 and 7.