Bug 1631321

Summary: koji: Remove (sub)packages from Fedora 30+: python2-koji-cli-plugins
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: kojiAssignee: Mike McLean <mikem>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: cstratak, dennis, igor.raits, jkeating, mhroncok, mikem, ngompa13, pviktori, rbarlow, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-01-17 11:07:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1625773    

Description Miro Hrončok 2018-09-20 11:12:19 UTC
In line with the Mass Python 2 Package Removal [0], the following (sub)packages of koji were marked for removal:

 * python2-koji-cli-plugins

According to our query, those (sub)packages only provide a Python 2 importable module. If this is not true, please tell us why, so we can fix our query.

Please remove them from your package.

As said in the change document, if there is no objection in a week, we will remove the package(s) as soon as we get to it. This change might not match your packaging style, so we'd prefer if you did the change. If you need more time, please let us know here.

We hope this doesn't come to you as a surprise. If you want to know our motivation for this, please read the change document [0].

[0] https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal

Comment 1 Miro Hrončok 2019-01-17 11:07:04 UTC
Removing just one subpackage doesn't make sense.

Looking forward to a Python 2-less Koji some day.

Comment 2 Zbigniew Jędrzejewski-Szmek 2019-01-17 11:15:11 UTC
Pfff. koji.rpm uses python3, but the rest is python2, and the code looks very much python3-incompatible.