Bug 1637771

Summary: unbound-libs-1.8.1-1.fc29(updates-testing) removes several packages
Product: [Fedora] Fedora Reporter: Xose Vazquez Perez <xose.vazquez>
Component: unboundAssignee: Paul Wouters <pwouters>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 29CC: pemensik, pj.pandit, pwouters
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: unbound-1.8.1-1.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-10-18 22:38:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Xose Vazquez Perez 2018-10-10 04:22:17 UTC
# dnf distro-sync -b --allowerasing --skip-broken 
Last metadata expiration check: 0:11:28 ago on Wed 10 Oct 2018 06:08:19 AM CEST.
Dependencies resolved.
======================================================================
 Package           Arch     Version           Repository         Size
======================================================================
Upgrading:
 unbound-libs      x86_64   1.8.1-1.fc29      updates-testing   461 k
Removing dependent packages:
 cups-devel        x86_64   1:2.2.8-5.fc29    @System           182 k
 gnutls-dane       x86_64   3.6.4-1.fc29      @System            43 k
 gnutls-devel      x86_64   3.6.4-1.fc29      @System           4.6 M
 gnutls-utils      x86_64   3.6.4-1.fc29      @System           1.4 M
 libvirt-client    x86_64   4.7.0-1.fc29      @System           880 k

Comment 1 Petr Menšík 2018-10-10 10:33:42 UTC
This was caused by unpushed update of gnutls, that was rebuild for unbound. It should be fixed once unbound updated with gnutls is pushed instead [1]. 
Unbound is pending into testing again, it should be ok by then.

1. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7be27ff1d8

Comment 2 Fedora Update System 2018-10-10 10:35:07 UTC
getdns-1.4.2-4.fc29 gnutls-3.6.4-2.fc29 netresolve-0.0.1-0.22.20160317git.fc29 unbound-1.8.1-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7be27ff1d8

Comment 3 Fedora Update System 2018-10-10 15:49:56 UTC
getdns-1.4.2-4.fc29, gnutls-3.6.4-2.fc29, netresolve-0.0.1-0.22.20160317git.fc29, unbound-1.8.1-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7be27ff1d8

Comment 4 Fedora Update System 2018-10-11 09:33:58 UTC
getdns-1.4.2-4.fc29 gnutls-3.6.4-2.fc29 libreswan-3.27-1.fc29 netresolve-0.0.1-0.22.20160317git.fc29 unbound-1.8.1-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7be27ff1d8

Comment 5 Fedora Update System 2018-10-11 18:59:32 UTC
getdns-1.4.2-4.fc29, gnutls-3.6.4-2.fc29, libreswan-3.27-1.fc29, netresolve-0.0.1-0.22.20160317git.fc29, unbound-1.8.1-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7be27ff1d8

Comment 6 Fedora Update System 2018-10-19 11:22:24 UTC
asterisk-16.0.0-1.fc29 getdns-1.4.2-4.fc29 gnutls-3.6.4-2.fc29 libreswan-3.27-1.fc29 netresolve-0.0.1-0.22.20160317git.fc29 unbound-1.8.1-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7be27ff1d8

Comment 7 Fedora Update System 2018-10-20 19:21:08 UTC
asterisk-16.0.0-1.fc29, getdns-1.4.2-4.fc29, gnutls-3.6.4-4.fc29, libreswan-3.27-1.fc29, netresolve-0.0.1-0.22.20160317git.fc29, unbound-1.8.1-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7be27ff1d8

Comment 8 Fedora Update System 2018-11-03 00:00:36 UTC
asterisk-16.0.0-1.fc29, getdns-1.4.2-4.fc29, gnutls-3.6.4-4.fc29, libreswan-3.27-1.fc29, netresolve-0.0.1-0.22.20160317git.fc29, unbound-1.8.1-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.