Bug 163985

Summary: mail-notification conflicts with evolution
Product: [Fedora] Fedora Reporter: Walter J. Mazurowski <wjmazurowski>
Component: mail-notificationAssignee: Thorsten Leemhuis <fedora>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: extras-qa
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-09-27 15:58:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 162161    

Description Walter J. Mazurowski 2005-07-22 16:44:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
mail-notification and Adelphia's PowerLink conflict. It appears mail-notification will not release the pop3 connection to Powerlink. I have had evolution installed and working for months (FC3 & FC4). I found out about mail-notification and added it to replace the missing "Inbox Monitor" from FC3. mail-notification installed and set-up fine. I wanted to use it to monitor my adelphia and msn accounts. I set-up both with the same information I used for evolution. The msn account works fine. (It uses HotWayd to access msn via port 110 of the local web browser.) The adelphia account has never worked. It uses a real pop3 server (mail.adelphia.net) on port 110. mail-notification continuously blinks. Whenever I start evolution and it goes to check for e-mail I get the password prompt. This repeats about 8 times then I get a "Error Fetching EMail". While mail-notification is running (have waited for about 2 hours) no e-mail gets received. Stopping mail-notification and the next evolution check will downloaded the e-mail that has arrived in the interim.

Version-Release number of selected component (if applicable):
mail-notification-1.1-3

How reproducible:
Always

Steps to Reproduce:
1. Start mail-notification
2. Run evoultion Send/Receive
3.
  

Actual Results:  Severl password prompts and then finally a "Error Fetching EMail" message.

Expected Results:  Fetch any e-mail if available. Note that if you leave mail-notification running the password/failure messages continue. As soon as you stop mail-notification the next Send/Receive works fine.

Additional info:

I have tried running mail-notification from the command line with the -enable-info switch but this provide no additional data on the problem. I suspected the "autodetect" and tried every Authentication Mechanism. Nothing worked any better than "autodetect". At this point mail-notification is useless, since I run evolution and have it set-up to download e-mails periodically. I thought mail-notification was an "Inbox Monitor" replacement which would catch my attention for newly arrived e-mail.

Comment 1 Thorsten Leemhuis 2005-07-23 16:11:04 UTC
Sound a bit strange. I (and it seems several other people, too) use
mail-notification in parallel with evolution (I use it with imap, you use pop3
-- maybe that's part of the problem).

Anyway, as a fedora-extras-packager I'm not the correct person to fix this. You
should complain to the developers of mail-notification:

http://www.nongnu.org/mailnotify/

But mail-notification itself uses gmime to access pop3 and other protocols iirc.
It is found at 

http://spruce.sourceforge.net/gmime/

The version in fedora-extras it not 100% up2date. Try to update to the latest by
installing:

http://www.leemhuis.info/files/fedorarpms/MISC.fdr/gmime-2.1.15-1.i386.rpm

If that helps I'll update the version in extras. Otherwise you should complain
to upstream developers.

Comment 2 Thorsten Leemhuis 2005-09-27 15:58:16 UTC
Closing. If this is still a issue with latest gmime and mail-notification please
reopen (or better: report upstream)