Bug 1640602

Summary: broken with latest alsa(1.1.7) release
Product: [Fedora] Fedora Reporter: Xose Vazquez Perez <xose.vazquez>
Component: alsa-libAssignee: Jaroslav Kysela <jkysela>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 29CC: bugs.michael, jkysela, malkodan, redhat-bugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: alsa-lib-1.1.7-2.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-10-30 17:29:05 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
debug output for comment 3
none
more debug output none

Description Xose Vazquez Perez 2018-10-18 11:51:31 UTC
ERROR util.cc:269 [audgui_simple_message]: ALSA error: snd_pcm_hw_params_set_period_time_near failed: Invalid argument.


https://www.alsa-project.org/main/index.php/Changes_v1.1.6_v1.1.7
alsa-lib-1.1.7-1.fc29
alsa-plugins-1.1.7-1.fc29
alsa-tools-1.1.7-2.fc29
alsa-utils-1.1.7-2.fc29


xmms is working fine.

Comment 1 Michael Schwendt 2018-10-22 21:42:48 UTC
Workaround: Increase the output buffer size to at least 2000 ms in Audacious' ALSA settings. Everything lower than that fails to work with the new ALSA.

Comment 2 Jaroslav Kysela 2018-10-23 07:03:30 UTC
It seems that this commit might be related:

http://git.alsa-project.org/?p=alsa-lib.git;a=commitdiff;h=9bb985c382bab8c3bf83c0d23f50195288d3cf9f

Comment 3 Jaroslav Kysela 2018-10-23 07:12:16 UTC
Could you compile alsa-lib from sources, enable RULES_DEBUG in alsa-lib/src/pcm/pcm_params.c and show the stderr output from audacious?

You can use LD_PRELOAD=..../alsa-lib/src/.libs/libasound.so.2.0.0 to avoid installation of library binaries for this test purpose.

Comment 4 Michael Schwendt 2018-10-23 12:30:53 UTC
Created attachment 1496690 [details]
debug output for comment 3

Comment 5 Jaroslav Kysela 2018-10-23 14:55:36 UTC
Thanks, please, enable also REFINE_DEBUG to analyze the complete log.

Comment 6 Michael Schwendt 2018-10-23 19:33:26 UTC
Created attachment 1496815 [details]
more debug output

Comment 7 Jaroslav Kysela 2018-10-24 07:19:07 UTC
Thanks, what's your hardware/plugins behind the 'default' device? Please, show output from:

  aplay -Ddefault -v -d 1 /dev/zero

The problem is that we end with the PERIOD_SIZE (2756 2757) interval which is empty for the natural numbers.

Comment 8 Jaroslav Kysela 2018-10-24 09:39:18 UTC
I can reproduce this with the loopback device:

~/.asoundrc:

  pcm.aloop44100 {
    type rate
    slave.pcm hw:Loopback
    slave.rate 44100
  }

$ LD_PRELOAD=./src/.libs/libasound.so.2.0.0 aplay -Daloop44100 -c2  -r 44100 -fS16_LE --period-time=62500 --buffer-size=11025  -v -d 1 /dev/zero

  aplay: set_params:1382: Unable to install hw params:
  ACCESS:  RW_INTERLEAVED
  FORMAT:  S16_LE
  SUBFORMAT:  STD
  SAMPLE_BITS: 16
  FRAME_BITS: 32
  CHANNELS: 2
  RATE: 44100
  PERIOD_TIME: [62494 62495)
  PERIOD_SIZE: (2755 2756]
  PERIOD_BYTES: (11020 11024]
  PERIODS: [4 5)
  BUFFER_TIME: (249977 249978)
  BUFFER_SIZE: 11024
  BUFFER_BYTES: 44096
  TICK_TIME: ALL

It works when 9bb985c382bab8c3bf83c0d23f50195288d3cf9f is reverted.

  http://git.alsa-project.org/?p=alsa-lib.git;a=commit;h=9bb985c382bab8c3bf83c0d23f50195288d3cf9f

Comment 10 Fedora Update System 2018-10-24 11:24:42 UTC
alsa-lib-1.1.7-2.fc29 alsa-plugins-1.1.7-2.fc29 alsa-tools-1.1.7-2.fc29 alsa-utils-1.1.7-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-4814c56802

Comment 11 Fedora Update System 2018-10-24 11:24:54 UTC
alsa-lib-1.1.7-2.fc29 alsa-plugins-1.1.7-2.fc29 alsa-tools-1.1.7-2.fc29 alsa-utils-1.1.7-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-4814c56802

Comment 12 Fedora Update System 2018-10-24 15:40:38 UTC
alsa-lib-1.1.7-2.fc29, alsa-plugins-1.1.7-2.fc29, alsa-tools-1.1.7-2.fc29, alsa-utils-1.1.7-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-4814c56802

Comment 13 Fedora Update System 2018-10-30 17:29:05 UTC
alsa-lib-1.1.7-2.fc29, alsa-plugins-1.1.7-2.fc29, alsa-tools-1.1.7-2.fc29, alsa-utils-1.1.7-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.