Bug 1641239

Summary: no action
Product: [Fedora] Fedora Reporter: cornosier
Component: system-config-languageAssignee: Parag Nemade <pnemade>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 29CC: i18n-bugs, nav007, pnemade, psatpute
Target Milestone: ---Keywords: i18n
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: system-config-language-3.5.0-1.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-12-15 03:18:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description cornosier 2018-10-20 09:50:25 UTC
Description of problem:

the application opens
after selecting the language, the ok button does not close the window because the program has crashed
below, console message

# system-config-language
Traceback (most recent call last):
  File "/usr/share/system-config-language/install_packages3.py", line 167, in setup_conditional_pkgs
    comps_fn = repo.metadata._comps_fn
AttributeError: 'Metadata' object has no attribute '_comps_fn'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/share/system-config-language/language_gui.py", line 307, in ok_btn
    installed = self.instpkg.install_packages3(dlang)
  File "/usr/share/system-config-language/install_packages3.py", line 238, in install_packages3
    self.setup_conditional_pkgs(repos)
  File "/usr/share/system-config-language/install_packages3.py", line 169, in setup_conditional_pkgs
    comps_fn = repo.metadata.comps_fn
AttributeError: 'Metadata' object has no attribute 'comps_fn'

thank you
GĂ©rard

Comment 1 Fedora Update System 2018-12-04 16:37:35 UTC
system-config-language-3.5.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-27e153fbd4

Comment 2 Fedora Update System 2018-12-05 03:54:23 UTC
system-config-language-3.5.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-27e153fbd4

Comment 3 cornosier 2018-12-06 07:53:55 UTC
thank you so much

Comment 4 Parag Nemade 2018-12-06 07:58:25 UTC
Thanks for testing this update.

Comment 5 Fedora Update System 2018-12-15 03:18:45 UTC
system-config-language-3.5.0-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.