Bug 1644858

Summary: no screen lock / screensaver support when started from GDM
Product: [Fedora] Fedora Reporter: Fabio Valentini <decathorpe>
Component: pantheon-session-settingsAssignee: Fabio Valentini <decathorpe>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 33CC: decathorpe, fred.passos
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: pantheon-session-settings-33.1-1.fc33 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-09-25 16:40:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1649555    

Description Fabio Valentini 2018-10-31 18:00:54 UTC
The Pantheon desktop currently has only hard-coded support for screen locking with light-locker, which in turn only works in sessions started by LightDM, and crashes everywhere else.

Since the primary way to get a Pantheon session on fedora is from fedora Workstation (which uses GDM), this isn't a good default experience.

The possible solutions I see are:

1) using gnome-screensaver when starting the Pantheon session from GDM
2) implementing a new, simple screensaver for Pantheon

Since option 2 is probably out of the scope of things that I / we can accomplish for fedora 30, using gnome-screensaver and patching session components to use standard screensaver / screen locking interfaces (instead of hard-coded light-locker interfaces) sounds much more manageable.

Comment 1 Ben Cotton 2019-08-13 16:52:20 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 2 Ben Cotton 2019-08-13 19:19:35 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 3 Fabio Valentini 2020-06-08 15:44:33 UTC
Moving to rawhide, since this is still true.

Comment 4 Ben Cotton 2020-08-11 13:05:25 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 33 development cycle.
Changing version to 33.

Comment 5 Fedora Update System 2020-08-31 12:31:34 UTC
FEDORA-2020-a3649e84c6 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-a3649e84c6

Comment 6 Fedora Update System 2020-08-31 18:57:55 UTC
FEDORA-2020-a3649e84c6 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-a3649e84c6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-a3649e84c6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2020-09-25 16:40:03 UTC
FEDORA-2020-a3649e84c6 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.