Bug 1646702 (CVE-2018-18928)

Summary: CVE-2018-18928 icu: integer overflow in number::impl::DecimalQuantity::toScientificString() in i18n/number_decimalquantity.cpp
Product: [Other] Security Response Reporter: Laura Pardo <lpardo>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED NOTABUG QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: abhgupta, ahughes, bmcclain, caillon+fedoraproject, caolanm, dbaker, dbhole, dblechte, denis.arnaud_fedora, dfediuck, eedri, eng-i18n-bugs, erack, jdulaney, john.j5live, jokerman, jvanek, mfabian, mgoldboi, michal.skrivanek, rhughes, rstrode, sandmann, sbonazzo, sherold, slawomir, sthangav, tpopela, trankin
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: icu 64.1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-20 21:18:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1646703, 1646704    
Bug Blocks: 1646705    

Description Laura Pardo 2018-11-05 21:12:00 UTC
International Components for Unicode (ICU) for C/C++ 63.1 has an integer overflow in number::impl::DecimalQuantity::toScientificString() in i18n/number_decimalquantity.cpp. 


References:
https://bugs.chromium.org/p/chromium/issues/detail?id=900059 
https://github.com/unicode-org/icu/commit/53d8c8f3d181d87a6aa925b449b51c4a2c922a51 
https://unicode-org.atlassian.net/browse/ICU-20246

Comment 1 Laura Pardo 2018-11-05 21:12:41 UTC
Created icu tracking bugs for this issue:

Affects: fedora-all [bug 1646703]

Comment 3 Riccardo Schirone 2018-11-12 13:19:39 UTC
Statement:

This issue did not affect the versions of icu as shipped with Red Hat Enterprise Linux 5, 6 and 7 as they did not include the vulnerable class.

This issue did not affect the versions of java-1.6.0-openjdk, java-1.7.0-openjdk and java-1.8.0-openjdk as shipped with Red Hat Enterprise Linux 5, 6 and 7 as they did not include the vulnerable class.

This issue did not affect the versions of webkitgtk4 as shipped with Red Hat Enterprise Linux 7 as they did not include the vulnerable class.

Comment 4 Product Security DevOps Team 2020-05-20 21:18:40 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2018-18928