Bug 1646739

Summary: Upgrade from 6.3.4 to 6.4 is failing on foreman-rake katello:import_subscriptions
Product: Red Hat Satellite Reporter: Mike McCune <mmccune>
Component: CandlepinAssignee: Barnaby Court <bcourt>
Status: CLOSED ERRATA QA Contact: Jitendra Yejare <jyejare>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.3.4CC: aperotti, jsherril, ktordeur, mmccune, pcreech, sghai, snemeth, zhunting
Target Milestone: 6.4.1Keywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: tfm-rubygem-katello-3.7.0.42-1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1642088 Environment:
Last Closed: 2018-12-06 22:32:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 2 Jitendra Yejare 2018-11-15 12:44:18 UTC
Verified!

@ Satellite 6.4.1 snap 1


Steps:

1. Upgrade Satellite from 6.3 to 6.4


Behavior:

1. Upgrade is successful
2. Subscription_import_all and pool_import_all works in console

# foreman-rake console
irb> User.current = User.first
irb> Katello::Subscription.import_all
irb> Katello::Pool.import_all 

3. The subscriptions are intact post upgrade and syncing of repos is working.

Comment 4 errata-xmlrpc 2018-12-06 22:32:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3799