Bug 1646742

Summary: [Satellite 6.2.14] Config group is not working with customer user role. (Failing with Stack level too deep)
Product: Red Hat Satellite Reporter: Mike McCune <mmccune>
Component: Users & RolesAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED ERRATA QA Contact: jcallaha
Severity: medium Docs Contact:
Priority: medium    
Version: 6.2.12CC: aperotti, dhlavacd, mhulan, mmccune, pcreech, rlavande, zhunting
Target Milestone: 6.4.1Keywords: Triaged
Target Release: Unused   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: foreman-1.18.0.39-1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1560672 Environment:
Last Closed: 2018-12-06 22:32:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1541321    
Attachments:
Description Flags
verification video none

Comment 3 jcallaha 2018-11-21 19:44:09 UTC
Verified in Satellite 6.4.1 Snap 1.

Following the reproducer steps, no issues were encountered while viewing hosts as the new user. See attached video for verification.

Comment 4 jcallaha 2018-11-21 19:44:27 UTC
Created attachment 1507800 [details]
verification video

Comment 6 errata-xmlrpc 2018-12-06 22:32:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3799

Comment 7 Mike McCune 2018-12-10 16:05:44 UTC
Description of problem:

Created a role and set Resource type = Host and Search = Config Group. Assign this role to the user and login with the user which is using this customized role. Go to Hosts page, it shows error = Stack level too deep. 

How reproducible:
Always

Steps to Reproduce:

1. Create a config group.

2.Add a role with resource type = Content Host, Host, Host Collection, Location and Host with config_group (Refer Image = 6.2.12.Customers_Filter-1.png)
 
3. and log in with that user and go to Hosts page in the satellite. We will get Stack level too deep error.

Actual results:

Facing issue = Stack level too deep error

Expected results:
User should be able to view the all hosts page in satellite.

Additional info:
We have reproduced same on 6.2.12, 6.2.13 and 6.3.0 and we are getting the same error.  While reproducing the issue we added some more resource types just confirm the permission details but we got the same error.