Bug 1650350

Summary: [DDF] So what are system utilities (eg. yum, subscription-manager, firewall-cmd) written in now? Or is this statement
Product: Red Hat Enterprise Linux 8 Reporter: Direct Docs Feedback <ddf-bot>
Component: DocumentationAssignee: Ioanna Gkioka <igkioka>
Documentation sub component: DDF QA Contact:
Status: CLOSED NOTABUG Docs Contact: Marie Hornickova <mdolezel>
Severity: unspecified    
Priority: unspecified CC: cstratak, hhorak, nesmith, pviktori, rhel-docs
Version: ---Keywords: Documentation
Target Milestone: rc   
Target Release: 8.0   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-01-29 10:41:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Direct Docs Feedback 2018-11-15 22:22:42 UTC
So what are system utilities (eg. yum, subscription-manager, firewall-cmd) written in now? Or is this statement referring just to the minimal install?

https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8-beta/html/8.0_beta_release_notes/overview#annotations:bc4b4afc-5a48-4369-a4ea-ef3df076550c

Comment 2 Marie Hornickova 2018-11-21 13:59:48 UTC
Hello!

Thank you very much for providing this feedback.

Red Hat Enterprise Linux 8 is distributed with Python 3.6. The package is not installed by default. To install Python 3.6, use the yum install python3 command.

Python 2.7 is available in the python2 package. However, Python 2 will have a shorter life cycle and its aim is to facilitate smoother transition to Python 3 for customers. 

For more information about using Python in RHEL 8, please see this documentation:

https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8-beta/html/configuring_basic_system_settings/using-python3


Unfortunately, I am not able to answer your question how this fact influences the languages in which particular components are written.

Honza and Charalampos, please could you help to answer this question?

Thank you!

Marie

Comment 3 Charalampos Stratakis 2018-11-21 14:24:32 UTC
So as far as I understand it, the question can be rephrased to "If no python is installed by default, how are system components written in python, able to function?".

This question can be seen answered here: https://developers.redhat.com/blog/2018/11/14/python-in-rhel-8/ at the platform-python section.

This is also mentioned briefly here: https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8-beta/html-single/configuring_basic_system_settings/#the_internal_platform_python_package

The main distinction is that system tools use a different interpreter than the one intended to be used directly by customers/users.

Do we need to make that distinction clear in the release notes somehow? Petr what would you think?

Comment 4 Marie Hornickova 2018-11-21 22:39:18 UTC
(In reply to Charalampos Stratakis from comment #3)
> So as far as I understand it, the question can be rephrased to "If no python
> is installed by default, how are system components written in python, able
> to function?".
> 
> This question can be seen answered here:
> https://developers.redhat.com/blog/2018/11/14/python-in-rhel-8/ at the
> platform-python section.
> 
> This is also mentioned briefly here:
> https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8-
> beta/html-single/configuring_basic_system_settings/
> #the_internal_platform_python_package
> 
> The main distinction is that system tools use a different interpreter than
> the one intended to be used directly by customers/users.
> 
> Do we need to make that distinction clear in the release notes somehow? Petr
> what would you think?

Charalampos, thanks a lot for providing these useful sources of information.

Comment 5 Petr Viktorin 2018-12-03 12:58:42 UTC
> Do we need to make that distinction clear in the release notes somehow? Petr what would you think?

Oh, I missed that question!

I don't think this particular detail needs to go in the Release Notes. A more authoritative place for it than the blog post would be somewhat nice to have, but I'm OK with the current state of things.

Comment 7 Ioanna Gkioka 2019-01-29 10:41:43 UTC
Thanks a lot for your feedback. No further action needed from the docs perspective.

Thus, I am closing this bug.