Bug 1650606

Summary: [OSP14][RFE] Optional NUMA affinity for PCI devices
Product: Red Hat OpenStack Reporter: Lee Yarwood <lyarwood>
Component: openstack-novaAssignee: Stephen Finucane <sfinucan>
Status: CLOSED ERRATA QA Contact: Maxim Babushkin <mbabushk>
Severity: high Docs Contact:
Priority: high    
Version: 14.0 (Rocky)CC: atelang, dasmith, derli, egallen, eglynn, fbaudin, jhakimra, jniu, joflynn, jraju, kchamart, lyarwood, markmc, mbabushk, mburns, mdeng, mschuppe, oblaut, panbalag, pchavva, rhos-flags, rhos-maint, sbauza, sclewis, sfinucan, sgordon, smooney, sputhenp, srevivo, supadhya, vromanso, weiyongjun, yohmura, yrachman
Target Milestone: z3Keywords: FutureFeature, Triaged, ZStream
Target Release: 14.0 (Rocky)   
Hardware: All   
OS: Linux   
URL: https://blueprints.launchpad.net/nova/+spec/share-pci-device-between-numa-nodes
Whiteboard: upstream_milestone_none upstream_definition_pending-approval upstream_status_unknown
Fixed In Version: openstack-nova-18.2.1-0.20190509150811.8e130e2.el7ost Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1561961 Environment:
Last Closed: 2019-07-02 19:45:01 UTC Type: Feature Request
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1647536, 1791991, 1366208, 1446311, 1561961, 1757886, 1775575, 1775576, 1783354    
Bug Blocks: 1188000, 1419948, 1422243, 1427361, 1442136, 1419231    

Comment 1 smooney 2018-11-23 11:53:46 UTC
note i have tested this on master (not osp 14) and found feature is broken.
as per http://post-office.corp.redhat.com/archives/rhos-compute/2018-November/msg00118.html i have reassined https://bugzilla.redhat.com/show_bug.cgi?id=1647536 to myself for now and will work with Stephen when he returns from PTO on the issue.

i am not chowing this BZ however i recommend discontinuing testing this feature until we can correct it upstream and backport the fixes.

Comment 2 Stephen Finucane 2018-12-03 17:35:59 UTC
Per the linked upstream bug, it appears there are some issues with this feature in its current guise. I'm going to follow on from Sean's testing and investigate these issues, which are blockers for any QE validation of this feature.

Comment 13 errata-xmlrpc 2019-07-02 19:45:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1670