Due to a recent update on Javascript code a full page refresh on your browser might be needed.

Bug 1651090

Summary: 404 errors on web console
Product: OpenShift Container Platform Reporter: Neeraj <nbhatt>
Component: Management ConsoleAssignee: Robb Hamilton <rhamilto>
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 3.11.0CC: aos-bugs, hasha, jokerman, mmccomas, nbhatt, spadgett, suchaudh, yapei
Target Milestone: ---Flags: hasha: needinfo? (spadgett)
Target Release: 3.11.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: Polling of quotas can result in undesirable toast notifications. Consequence: Users see unnecessary toast notifications. Fix: Suppressing quota polling errors fixes the bug. Result: Users no longer see undesirable toast notifications.
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-02-20 14:11:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Neeraj 2018-11-19 07:53:03 UTC
Description of problem:

An error occurred connecting to the server.
 Failed to list appliedclusterresourcequotas/quota.openshift.io/v1 (status 404)
Refresh
CloseerrorAn error occurred connecting to the server.
 Failed to list resourcequotas/v1 (status 404)
Refresh


Additional info: 
- Workaround:
  - Normally refreshing the web-page should resolve this issue.
https://access.redhat.com/solutions/3467801


This is not expected to refresh the page several times. Seeking for a proper resolution.

Comment 1 Samuel Padgett 2018-11-19 13:31:46 UTC
Are you seeing this on the project overview page? We poll quota status to show warnings when you are at or over quota. If this request fails, the console should continue to work, and the next poll might be successful. The only drawback is you won't be warned about quota. I understand how the errors are intrusive, however.

To help us troubleshoot, can you capture the failing network requests in Chrome developer tools?

1. Open Chrome developer tools with Ctrl-Shift-I or Cmd-Shift-I on a mac
2. Switch to the Network tab
3. Reproduce the problem
4. Right click one of the rows and select "Save as HAR with Content"
5. Attach the content to the issue

https://developers.google.com/web/tools/chrome-devtools/network-performance/reference#save-as-har

Thanks!

Comment 6 Yadan Pei 2018-12-11 09:39:13 UTC
QE tried to reproduce on testing env(openshift v3.11.54), don't find popup errors.

Will give another look if customer provide more details

Comment 8 Yadan Pei 2018-12-18 03:11:47 UTC
Hi,

nothing special, we need data Sam had requested in comment 1

Comment 9 Samuel Padgett 2019-01-23 15:10:11 UTC
Since we poll quota resources, I think a reasonable fix is just to suppress the errors since

1. We'll retry anyway at the next polling interval
2. This will avoid displaying a prominent and annoying error message for a potentially transient error
3. It's a non-critical function on this page. We poll quota only to show a warning in the notification drawer if you are at or over quota. If quota problems are preventing rollouts of your deployments, this will still be called out as errors in the overview page, so important errors are still surfaced.

Comment 10 Robb Hamilton 2019-01-23 21:20:01 UTC
PR to resolve: https://github.com/openshift/origin-web-console/pull/3109

Comment 12 shahan 2019-02-12 05:08:05 UTC
 Sam,

   QE cannot reproduce this issue on testing env v3.11.69(not include bug's fix), could you point me out the steps to reproduce? thanks in advance!

Comment 13 shahan 2019-02-12 09:39:09 UTC
Or some checkpoints for verifying this bug. Thanks!

Comment 14 Yadan Pei 2019-02-13 08:21:13 UTC
v3.11.82 includes the fix

$ git log atomic-openshift-web-console-3.11.82-1 -1
commit 0ff1e2620bf355d36998510e1e2f4bbc2a80c4d9 (tag: atomic-openshift-web-console-3.11.82-1)
Author: AOS Automation Release Team <aos-team-art@redhat.com>
Date:   Thu Feb 7 20:10:08 2019 -0500

    bump origin-web-console 47a8bb4a

$  git log --pretty="%h %cd - %s" 47a8bb4a | grep '#3109'
6e1962ea Wed Jan 23 22:46:33 2019 +0100 - Merge pull request #3109 from rhamilto/bz1651090




QE tries to verify the bug and we don't see error popups when:
1. Switch projects, and browsing project Overview 
2. Log out and Login

Here's a recording http://g.recordit.co/9WtmXKTSg4.gif

Will move to VERIFIED since the reported issues not exists on v3.11.82

Comment 15 Yadan Pei 2019-02-13 08:21:42 UTC
Feel free to Reopen if there's any other problem

Comment 17 errata-xmlrpc 2019-02-20 14:11:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0326