Bug 1651105

Summary: rgw-manager role is not working
Product: Red Hat Ceph Storage Reporter: Uday kurundwade <ukurundw>
Component: Ceph-DashboardAssignee: Ernesto Puerta <epuertat>
Status: CLOSED DUPLICATE QA Contact: Ernesto Puerta <epuertat>
Severity: high Docs Contact:
Priority: unspecified    
Version: 3.2CC: ceph-eng-bugs
Target Milestone: rc   
Target Release: 3.*   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-11-19 11:23:44 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Screenshot of forbidden page none

Description Uday kurundwade 2018-11-19 08:40:10 UTC
Created attachment 1507134 [details]
Screenshot of forbidden page

Description of problem:
rgw-manager is roles not working in dashboard

Version-Release number of selected component (if applicable):
ceph-mgr-12.2.8-32.el7cp.x86_64
ceph-ansible-3.2.0-0.1.beta9.el7cp.noarch
ceph-common-12.2.8-32.el7cp.x86_64

How reproducible:
Always
Steps to Reproduce:
1.Install ceph storage with RGW
2.Install "dashboard v2" by running ansible playbook
3.Login to dashboard after installation of dashboard v2
4.Create new user and assign "rgw-manager" role to that user. 
5.Log in with newly created rgw-manager user.
6.Navigate to Object Gateway -> Daemons.

Actual results:
Throwing 403 Forbidden error (Sorry, you are not allowed to see what you were looking for)

Expected results:
It should be accessible

Additional info:
It is accessible through Administrator role

Comment 3 Ernesto Puerta 2018-11-19 11:23:44 UTC

*** This bug has been marked as a duplicate of bug 1649711 ***