Bug 1651181

Summary: python-cornice-sphinx: Remove (sub)packages from Fedora 30+: python2-cornice-sphinx
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: python-cornice-sphinxAssignee: Miro Hrončok <mhroncok>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: cstratak, i.gnatenko.brain, mhroncok, ngompa13, pviktori, rbarlow, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-cornice-sphinx-0.3-7.fc30 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-12-06 21:36:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1625773, 1655719    

Description Miro Hrončok 2018-11-19 10:56:35 UTC
In line with the Mass Python 2 Package Removal [0], the following (sub)packages of python-cornice-sphinx were marked for removal:

 * python2-cornice-sphinx

According to our query, those (sub)packages only provide a Python 2 importable module. If this is not true, please tell us why, so we can fix our query.

Please remove them from your package.

As said in the change document, if there is no objection in a week, we will remove the package(s) as soon as we get to it. This change might not match your packaging style, so we'd prefer if you did the change. If you need more time, please let us know here.

If you do the change yourself, it would help us a lot by reducing the amount of packages we need to mass change.

We hope this doesn't come to you as a surprise. If you want to know our motivation for this, please read the change document [0].

[0] https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal

Comment 1 Miro Hrončok 2018-12-03 18:57:20 UTC
I was trying to remove the package, but it FTBFS:

+ nosetests-3
..E.
======================================================================
ERROR: test_string_validator_resolved (tests.TestServiceDirective)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/cornice.ext.sphinx-0.3/tests/__init__.py", line 48, in test_string_validator_resolved
    ret = self.directive.run()
  File "/builddir/build/BUILD/cornice.ext.sphinx-0.3/cornice_sphinx/__init__.py", line 78, in run
    app.main({})
  File "/builddir/build/BUILD/cornice.ext.sphinx-0.3/tests/dummy/__init__.py", line 11, in main
    return config.make_wsgi_app()
  File "/usr/lib/python3.7/site-packages/pyramid/config/__init__.py", line 1052, in make_wsgi_app
    self.commit()
  File "/usr/lib/python3.7/site-packages/pyramid/config/__init__.py", line 684, in commit
    self.action_state.execute_actions(introspector=self.introspector)
  File "/usr/lib/python3.7/site-packages/pyramid/config/__init__.py", line 1197, in execute_actions
    action = next(action_iter, None)
  File "/usr/lib/python3.7/site-packages/pyramid/config/__init__.py", line 1379, in resolveConflicts
    raise ConfigurationConflictError(conflicts)
pyramid.exceptions.ConfigurationConflictError: Conflicting configuration actions
  For: ('view', None, '', 'collection_thing_service', 'a9204cf84fd843dac4e2dad4c4b72fed')
    Line 42 of file /builddir/build/BUILD/cornice.ext.sphinx-0.3/tests/dummy/views.py:
        config.add_cornice_resource(thing_resource)
    Line 42 of file /builddir/build/BUILD/cornice.ext.sphinx-0.3/tests/dummy/views.py:
        config.add_cornice_resource(thing_resource)
  For: ('view', None, '', 'collection_thing_service', 'b1b988966518e8d3f972d463b864549f')
    Line 42 of file /builddir/build/BUILD/cornice.ext.sphinx-0.3/tests/dummy/views.py:
        config.add_cornice_resource(thing_resource)
    Line 42 of file /builddir/build/BUILD/cornice.ext.sphinx-0.3/tests/dummy/views.py:
        config.add_cornice_resource(thing_resource)

----------------------------------------------------------------------
Ran 4 tests in 0.275s

FAILED (errors=1)



This happened also prior to the removal:

+ nosetests-2
..E.
======================================================================
ERROR: test_string_validator_resolved (tests.TestServiceDirective)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/cornice.ext.sphinx-0.3/tests/__init__.py", line 48, in test_string_validator_resolved
    ret = self.directive.run()
  File "/builddir/build/BUILD/cornice.ext.sphinx-0.3/cornice_sphinx/__init__.py", line 78, in run
    app.main({})
  File "/builddir/build/BUILD/cornice.ext.sphinx-0.3/tests/dummy/__init__.py", line 11, in main
    return config.make_wsgi_app()
  File "/usr/lib/python2.7/site-packages/pyramid/config/__init__.py", line 1052, in make_wsgi_app
    self.commit()
  File "/usr/lib/python2.7/site-packages/pyramid/config/__init__.py", line 684, in commit
    self.action_state.execute_actions(introspector=self.introspector)
  File "/usr/lib/python2.7/site-packages/pyramid/config/__init__.py", line 1197, in execute_actions
    action = next(action_iter, None)
  File "/usr/lib/python2.7/site-packages/pyramid/config/__init__.py", line 1379, in resolveConflicts
    raise ConfigurationConflictError(conflicts)
ConfigurationConflictError: Conflicting configuration actions
  For: ('view', None, '', 'collection_thing_service', 'a9204cf84fd843dac4e2dad4c4b72fed')
    Line 42 of file /builddir/build/BUILD/cornice.ext.sphinx-0.3/tests/dummy/views.py:
        config.add_cornice_resource(thing_resource)
    Line 42 of file /builddir/build/BUILD/cornice.ext.sphinx-0.3/tests/dummy/views.py:
        config.add_cornice_resource(thing_resource)
  For: ('view', None, '', 'collection_thing_service', 'b1b988966518e8d3f972d463b864549f')
    Line 42 of file /builddir/build/BUILD/cornice.ext.sphinx-0.3/tests/dummy/views.py:
        config.add_cornice_resource(thing_resource)
    Line 42 of file /builddir/build/BUILD/cornice.ext.sphinx-0.3/tests/dummy/views.py:
        config.add_cornice_resource(thing_resource)

----------------------------------------------------------------------
Ran 4 tests in 0.209s

FAILED (errors=1)




This build fine on Fedora 29 with cornice 3.1.0, but fails on rawhide with cornice 3.4.0.

Any ideas? Should we temporarily skip the failing test? Report to upstream?

Comment 2 Miro Hrončok 2018-12-03 19:00:25 UTC
Reported as https://github.com/Cornices/cornice.ext.sphinx/issues/19

Comment 3 Randy Barlow 2018-12-03 20:25:32 UTC
Thanks for reporting that Miro!

This sounds similar to the Bodhi issue I linked in the upstream issue. I wouldn't be opposed to skipping that test until upstream fixes or at least comments about it.

BTW, I think I have ACLs on this upstream project because I might be the only person who cares about it anymore (though I don't have privs to release it on PyPI) so I might end up being the person to fix it there anyway ☺