Bug 1651776

Summary: The entire plan content is output to stdout during deployment
Product: Red Hat OpenStack Reporter: Marius Cornea <mcornea>
Component: openstack-tripleo-commonAssignee: John Fulton <johfulto>
Status: CLOSED ERRATA QA Contact: Gurenko Alex <agurenko>
Severity: high Docs Contact:
Priority: high    
Version: 14.0 (Rocky)CC: agurenko, ahrechan, dbecker, emacchi, jcoufal, jjoyce, johfulto, mburns, morazi, ramishra, rhos-flags, slinaber
Target Milestone: rcKeywords: Regression, Triaged
Target Release: 14.0 (Rocky)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-common-9.4.1-0.20181012010878.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-01-11 11:54:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
overcloud_scale_up.log
none
overcloud_install.log none

Description Marius Cornea 2018-11-20 19:30:03 UTC
Created attachment 1507454 [details]
overcloud_scale_up.log

Description of problem:

When doing stack updates the entire plan content is output to stdout. This is recently introduced as it wasn't there before. Moreover it is not user friendly at all as it fills out the console with a lot of data not relevant to the user.

Version-Release number of selected component (if applicable):
python-tripleoclient-10.6.1-0.20181010222405.8c8f259.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP14
2. Scale out with one additional compute

Actual results:
The plan content gets to stdout during scale out.

Expected results:
The plan content doesn't get to stdout.

Additional info:
Attaching an example.

Comment 1 Artem Hrechanychenko 2018-11-20 19:40:15 UTC
Created attachment 1507456 [details]
overcloud_install.log

that issue also appears when you do regular deployment also

Comment 3 Marius Cornea 2018-11-20 19:48:44 UTC
Changing the title as this happens during initial deployment as well.

Comment 5 Emilien Macchi 2018-11-20 20:30:17 UTC
Caused by https://review.openstack.org/#/c/613373

Comment 17 Artem Hrechanychenko 2018-11-27 13:23:49 UTC
VERIFIED

openstack-tripleo-common-9.4.1-0.20181012010878.el7ost.noarch

Comment 20 errata-xmlrpc 2019-01-11 11:54:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045