Bug 1652020 (CVE-2018-16854)

Summary: CVE-2018-16854 moodle: Login CSRF vulnerability in login form
Product: [Other] Security Response Reporter: Laura Pardo <lpardo>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED UPSTREAM QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: gwync, igor.raits
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: moodle 3.6, moodle 3.5.3, moodle 3.4.6, moodle 3.3.9, moodle 3.1.15 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-10 10:43:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1652021, 1652022    
Bug Blocks:    

Description Laura Pardo 2018-11-21 12:34:25 UTC
A flaw was found in moodle before versions 3.6, 3.5.3, 3.4.6, 3.3.9 and 3.1.15. The login form is not protected by a token to prevent login cross-site request forgery.


References:
https://moodle.org/mod/forum/discuss.php?d=378731

Upstream Patch:
http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-63183

Comment 1 Laura Pardo 2018-11-21 12:34:55 UTC
Created moodle tracking bugs for this issue:

Affects: epel-all [bug 1652022]
Affects: fedora-all [bug 1652021]

Comment 2 Product Security DevOps Team 2019-06-10 10:43:03 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.