Bug 1652063

Summary: Creation of /subsystem=naming/binding resource with Environment field fails
Product: [JBoss] JBoss Operations Network Reporter: Filip Brychta <fbrychta>
Component: Plugin -- JBoss EAP 6Assignee: Ruben Vargas Palma <rvargasp>
Status: CLOSED CURRENTRELEASE QA Contact: Filip Brychta <fbrychta>
Severity: medium Docs Contact:
Priority: high    
Version: JON 3.3.11CC: mfoley, miburman, rvargasp, spinder
Target Milestone: ER01Keywords: Triaged
Target Release: One-off release   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1652061 Environment:
Last Closed: 2019-05-16 09:27:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1657856    

Description Filip Brychta 2018-11-21 14:07:13 UTC
+++ This bug was initially created as a clone of Bug #1652061 +++

Description of problem:
Creation of /subsystem=naming/binding resource with Environment field fails with:
WFLYCTL0097: Wrong type for 'environment'. Expected [OBJECT] but was LIST, rolled-back=true

Version-Release number of selected component (if applicable):
JON 3.3.11, EAP plugin pack 08.CR01
EAP 6.4.21

How reproducible:
Always

Steps to Reproduce:
1. navigate to EAP6 Standalone Server resource -> Subsystems -> naming -> Inventory -> Create Child -> Binding
2. Set name: java:global/MongoClient
3. Set binding type: object-factory
4. Set module: com.mongodb.jndi
5. Set class: com.mongodb.jndi.MongoClientJNDIFactory
6. Add environment property: name: mongoClientURI, value: mongodb://username:password@yourdomain.com:27017,username:password@yourdomain.com:27017
7. Finish

Actual results:
Creation fails with:
WFLYCTL0097: Wrong type for 'environment'. Expected [OBJECT] but was LIST, rolled-back=true

Expected results:
Resource is created

Additional info:
Tried also simple binding type with the same result.

Comment 1 Michael Burman 2019-03-22 09:17:34 UTC
This was discussed in:

https://bugzilla.redhat.com/show_bug.cgi?id=1477945

Comment 2 Ruben Vargas Palma 2019-04-02 17:53:34 UTC
Hi,

This issue is different, is not the same as https://bugzilla.redhat.com/show_bug.cgi?id=1477945 

This is at creation time, other is when the resource is read or updated.

I sent a PR: https://github.com/rhq-project/rhq/pull/373