Bug 1652672

Summary: Build pcp-export-pcp2elasticsearch for CentOS and Fedora
Product: [oVirt] ovirt-distribution Reporter: Sandro Bonazzola <sbonazzo>
Component: RFEsAssignee: Shirly Radco <sradco>
Status: CLOSED WONTFIX QA Contact: Lukas Svaty <lsvaty>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: ---CC: bugs, lberk, mgoodwin, nathans
Target Milestone: ---Keywords: FutureFeature
Target Release: ---Flags: sradco: ovirt-future?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-04-30 08:39:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Metrics RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Sandro Bonazzola 2018-11-22 14:56:03 UTC
pcp-export-pcp2elasticsearch is needed for the new metrics stack and is not available neither in CentOS nor in Fedora.

Comment 1 Nathan Scott 2018-11-23 02:34:37 UTC
Sandro, this package should now be available in Fedora (as of pcp-4.2.0 - quite recently released) and should soon (if Lukas has not already done so) be available via the rhlog-1.0 branch for CentOS.

Comment 2 Shirly Radco 2018-11-25 15:07:58 UTC
(In reply to Nathan Scott from comment #1)
> Sandro, this package should now be available in Fedora (as of pcp-4.2.0 -
> quite recently released) and should soon (if Lukas has not already done so)
> be available via the rhlog-1.0 branch for CentOS.

Roy Golan has submitted a PR for this plugin.
Please review.
https://github.com/performancecopilot/pcp/pull/581
If the package with this fix will not be available for EL7 we will need to build it.

Comment 3 Sandro Bonazzola 2018-11-28 09:41:40 UTC
pcp 4.2.0 included in Fedora 29 and Fedora 28 has pcp-export-pcp2elasticsearch subpackage.

Shirly can you please check if 4.2.0 contains https://github.com/performancecopilot/pcp/pull/581 ?

The plugin is missing in pcp-4.1.0-5.el7_6 build shipped with RHEL 7.6 and CentOS 7.6.

Comment 5 Shirly Radco 2018-11-28 11:56:53 UTC
(In reply to Sandro Bonazzola from comment #3)
> pcp 4.2.0 included in Fedora 29 and Fedora 28 has
> pcp-export-pcp2elasticsearch subpackage.
> 
> Shirly can you please check if 4.2.0 contains
> https://github.com/performancecopilot/pcp/pull/581 ?

It was merged only today.
> 
> The plugin is missing in pcp-4.1.0-5.el7_6 build shipped with RHEL 7.6 and
> CentOS 7.6.

Comment 7 Sandro Bonazzola 2019-04-30 08:39:32 UTC
After discussing this with Shirly, closing since there's no real gain at this point with the solution we already have with collectd + rsyslog.