Bug 1652683

Summary: neverputt won't start game
Product: [Fedora] Fedora Reporter: Tom Horsley <horsley1953>
Component: neverballAssignee: Gwyn Ciesla <gwync>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 29CC: gwync, sergio, wart
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: neverball-1.6.0-16.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-02-21 02:56:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tom Horsley 2018-11-22 15:16:37 UTC
Description of problem:

Just tried running neverputt for the first time in a long time, and I get through all the initial screens OK, then it asks me how many players and when I click on any of the numbers, nothing happens, the game does not start. Running it in a terminal doesn't show any useful info, just this:

zooty> neverputt
Creating a window (1920x1080, windowed)
Created a window (2, 1920x1080, windowed)

That message comes out as soon as I start it.

I'm running in X11, not Wayland, and I'm using the nvidia binary drivers (but other 3D things work OK like glxgears).

Version-Release number of selected component (if applicable):

neverball-neverputt-1.6.0-15.fc29.x86_64
neverball-1.6.0-15.fc29.x86_64

How reproducible:
100%

Steps to Reproduce:
1.see above
2.
3.

Actual results:
never starts the game

Expected results:
play silly golf game

Additional info:
I probably haven't tried to run this for a long time, so this may not be new in fedora 29.

Comment 1 Tom Horsley 2018-11-22 15:38:26 UTC
And the problem is packaging. I ran it under strace, and saw errors like this:

openat(AT_FDCWD, "/usr/share/neverball/map-putt/01_easy.sol", O_RDONLY) = -1 EACCES (Permission denied)

Checking the file, I see:

zooty> ls -l /usr/share/neverball/map-putt/01_easy.sol
-rw------- 1 root root 13564 Aug  1 14:08 /usr/share/neverball/map-putt/01_easy.sol

I then did this as root:

[root@zooty ~]# find /usr/share/neverball -type d -print0 | xargs -0 chmod 755
[root@zooty ~]# find /usr/share/neverball -type f -print0 | xargs -0 chmod a+r

And I can run neverputt again.

Comment 2 Sergio Basto 2019-02-12 03:37:42 UTC
(In reply to Tom Horsley from comment #1)
> [root@zooty ~]# find /usr/share/neverball -type d -print0 | xargs -0 chmod
> 755
> [root@zooty ~]# find /usr/share/neverball -type f -print0 | xargs -0 chmod
> a+r
> 
> And I can run neverputt again.

It also fixes things for me 

I bet that is this commit 
https://src.fedoraproject.org/fork/sergiomb/rpms/neverball/c/2f62b1fdfc08948e7406d99bbaa3f2f0b3461566?branch=master

@Gwyn Ciesla can we try revert this commit for F29 please 

Thanks.

Comment 3 Fedora Update System 2019-02-12 15:26:02 UTC
neverball-1.6.0-16.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-042092c80d

Comment 4 Fedora Update System 2019-02-12 20:26:21 UTC
neverball-1.6.0-16.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-042092c80d

Comment 5 Fedora Update System 2019-02-21 02:56:48 UTC
neverball-1.6.0-16.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.