Bug 1652737

Summary: role & addons should not affect entitlement compliance status
Product: [Community] Candlepin Reporter: Nikos Moumoulidis <nmoumoul>
Component: candlepinAssignee: Nikos Moumoulidis <nmoumoul>
Status: CLOSED CURRENTRELEASE QA Contact: Katello QA List <katello-qa-list>
Severity: high Docs Contact:
Priority: high    
Version: 2.5CC: redakkan, skallesh
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: candlepin-2.6.1-1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1652738 1654445 (view as bug list) Environment:
Last Closed: 2019-01-23 16:56:08 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1652738, 1654445    

Description Nikos Moumoulidis 2018-11-22 18:25:49 UTC
Description of problem:
When syspurpose role or addon(s) are specified on the client, and the system is attached to a subscription that happens to have mismatched roles/addons with those of the consumer, the Entitlement Compliance status is wrongly reported as invalid or insufficient. role/addon attributes should only have an effect on the Syspurpose Compliance status, and not on the Entitlement Compliance status.

Version-Release number of selected component (if applicable):
candlepin 2.3, 2.5 and master

How reproducible:
100%

Steps to Reproduce:
1. Set your system syspurpose role to 'my_role'.
2. Have an installed product called 'product1'.
3. Attach the system to a subscription that provides product1, but the only role it has is 'provided_role'.
4. Run 'subscription-manager status' to see the Overall Status

Actual results:
The Overall Status is either 'invalid' or 'partial'.

Expected results:
The Overall Status should be 'valid', because product1 is covered, and roles/addons should have no effect on it.

Additional info: