Bug 1653736

Summary: Options deplist, repoquery do not return expected packages
Product: [Fedora] Fedora Reporter: ricky.tigg
Component: dnfAssignee: Jaroslav Mracek <jmracek>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 29CC: dmach, mblaha, mhatina, packaging-team-maint, rpm-software-management, vmukhame
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: dnf-4.2.5-4.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-31 01:38:52 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description ricky.tigg 2018-11-27 14:11:33 UTC
Description of problem:: deplist, repoquery, do not return expected packages.

Version-Release number component: dnf.noarch 4.0.4-2.fc29

– None of packages shutter or openssl are installed –
Steps to Reproduce:

$ sudo dnf install shutter
Package			Version
================================================
Installing:			
shutter				0.93.1-11.fc29
Installing			
openssl				1:1.1.1-3.fc29
perl-IO-Socket-SSL		2.060-2.fc29
perl-LWP-Protocol-https		6.07-6.fc29
perl-Net-HTTP			6.18-3.fc29
perl-Net-OAuth			0.28-16.fc29
perl-WWW-Mechanize		1.88-4.fc29
perl-WebService-Dropbox		2.07-5.fc29
perl-XML-SAX			1.00-3.fc29
perl-XML-Simple			2.25-3.fc29
perl-libwww-perl		6.35-1.fc2

$ dnf deplist shutter | grep openssl
Last metadata expiration check: 0:45:29 ago on Tue 27 Nov 2018 14:14:03 CET.
$ 

$ dnf repoquery --whatrequires openssl | grep shutter
Last metadata expiration check: 0:36:32 ago on Tue 27 Nov 2018 14:14:03 CET.
$ 

Actual results: from 'dnf install shutter', it appears that shutter depends on openssl. In other words it requires it.

Expected results:
'deplist shutter' – to return 'openssl'
'repoquery --whatrequires openssl' – to return 'shutter'

Comment 1 Daniel Mach 2018-12-03 12:40:32 UTC
I believe it's because openssl is not a direct dependency of the shutter package.
openssl is listed when you run:
$ dnf repoquery --requires shutter --recursive --resolve

Would you be fine with following changes?
* document dnf deplist in the man pages
* explain that it doesn't recursively resolve deps
* create a new option --recursive for the deplist command

Comment 2 ricky.tigg 2018-12-03 13:44:36 UTC
Certainly, as you suggested them as a developer, and assuming mainly that you would be fine with those changes.

Comment 3 Jaroslav Mracek 2019-07-26 10:15:00 UTC
I added a description of deplist command https://github.com/rpm-software-management/dnf/pull/1443.
I also consider to create a new option --recursive for the deplist command as an overkill. It will produce to many entries therefore setting it as out of scope for the bug report.

Comment 4 Fedora Update System 2019-08-14 07:24:01 UTC
FEDORA-2019-d4b6ede072 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d4b6ede072

Comment 5 Fedora Update System 2019-08-16 20:12:22 UTC
dnf-4.2.5-4.fc29, dnf-plugins-extras-4.0.4-2.fc29, libdnf-0.31.0-6.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d4b6ede072

Comment 6 Fedora Update System 2019-08-31 01:38:52 UTC
dnf-4.2.5-4.fc29, dnf-plugins-extras-4.0.4-2.fc29, libdnf-0.31.0-6.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.