Bug 1654165

Summary: Service not showing VMs belong to
Product: Red Hat CloudForms Management Engine Reporter: Gellert Kis <gekis>
Component: AutomateAssignee: Greg McCullough <gmccullo>
Status: CLOSED CURRENTRELEASE QA Contact: Niyaz Akhtar Ansari <nansari>
Severity: medium Docs Contact: Red Hat CloudForms Documentation <cloudforms-docs>
Priority: high    
Version: 5.9.0CC: awight, bmidwood, dmetzger, fdewaley, gekis, lavenel, mkanoor, nansari, obarenbo, simaishi, sshveta, tfitzger, vaclav.miller
Target Milestone: GAKeywords: TestOnly, ZStream
Target Release: 5.10.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 5.10.0.28 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1655773 1660603 (view as bug list) Environment:
5.9.5.3
Last Closed: 2019-02-12 16:50:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: Bug
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1655773, 1660603    

Comment 2 Allen W 2018-11-29 18:13:59 UTC
Hi Gellert, can we get a machine exhibiting this issue?

Comment 3 Allen W 2018-11-29 18:16:53 UTC
Woops I should read more clearly, thanks to your original post! This looks like a classic ui issue (from looking at the screenshots) is that correct?

Comment 7 Tina Fitzgerald 2018-11-30 13:50:10 UTC
We've identified this to be a service resource linking issue, and are working on a fix.

Comment 8 Tina Fitzgerald 2018-11-30 15:37:39 UTC
This issue is resolved with the following PR:
https://github.com/ManageIQ/manageiq/pull/18252

Comment 11 Tina Fitzgerald 2018-12-17 20:23:29 UTC
Adding 5.8.z flag per conversation with Dennis.

Comment 13 Tina Fitzgerald 2019-01-04 16:07:55 UTC
Correction to comment 8. The following PR resolves the reported issue:
https://github.com/ManageIQ/manageiq/pull/18251

Comment 15 Tina Fitzgerald 2019-01-24 15:57:41 UTC
Hi Niyaz,

Provisioning Service bundles with the affected code causes the underlying resources(VMs) to not be properly displayed when viewing the provisioned Service.

1. Create a Service Bundle, containing 2 service items, each of which will provision a single VM. (VMware for instance)
2. Order the Service bundle.
3. View the Service. There will likely be only a single VM displayed, instead of the 2 expected VMs.
  

Let me know if you have any questions.

Thanks,
Tina