Bug 1655346

Summary: SELinux is preventing certwatch from 'write' accesses on the directory /home.
Product: [Fedora] Fedora Reporter: Doug Hutcheson <owlbrudder>
Component: selinux-policyAssignee: Lukas Vrabec <lvrabec>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 29CC: dwalsh, gnu699, lvrabec, mgrepl, plautrba
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:92d0866e1cdc8a5b8340f938692c859e8432dca16cf734e664fe757045c086ad;VARIANT_ID=workstation;
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-12-12 14:35:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Doug Hutcheson 2018-12-03 00:22:51 UTC
Description of problem:
This happens every morning when I fire up my laptop.
SELinux is preventing certwatch from 'write' accesses on the directory /home.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that certwatch should be allowed write access on the home directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'certwatch' --raw | audit2allow -M my-certwatch
# semodule -X 300 -i my-certwatch.pp

Additional Information:
Source Context                system_u:system_r:certwatch_t:s0-s0:c0.c1023
Target Context                system_u:object_r:home_root_t:s0
Target Objects                /home [ dir ]
Source                        certwatch
Source Path                   certwatch
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    <Unknown>
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.19.4-300.fc29.x86_64 #1 SMP Fri
                              Nov 23 13:03:11 UTC 2018 x86_64 x86_64
Alert Count                   128
First Seen                    2018-11-26 08:56:37 AEST
Last Seen                     2018-12-03 10:08:38 AEST
Local ID                      e8d0b967-41b3-4d81-95e3-cab520db0491

Raw Audit Messages
type=AVC msg=audit(1543795718.635:10533): avc:  denied  { write } for  pid=22300 comm="certwatch" name="/" dev="dm-2" ino=2 scontext=system_u:system_r:certwatch_t:s0-s0:c0.c1023 tcontext=system_u:object_r:home_root_t:s0 tclass=dir permissive=0


Hash: certwatch,certwatch_t,home_root_t,dir,write


Additional info:
component:      selinux-policy
reporter:       libreport-2.9.6
hashmarkername: setroubleshoot
kernel:         4.19.4-300.fc29.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2018-12-12 14:35:42 UTC

*** This bug has been marked as a duplicate of bug 1655357 ***