Bug 1655459

Summary: [abrt] [faf] sssd: raise(): /usr/libexec/sssd/proxy_child killed by 6
Product: Red Hat Enterprise Linux 8 Reporter: Madhuri <mupadhye>
Component: sssdAssignee: SSSD Maintainers <sssd-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Steeve Goveas <sgoveas>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 8.0CC: grajaiya, jhrozek, lslebodn, mupadhye, mzidek, pbrezina, sgoveas, tscherf
Target Milestone: rc   
Target Release: 8.0   
Hardware: Unspecified   
OS: Unspecified   
URL: http://faf.lab.eng.brq.redhat.com/faf/reports/bthash/65a7dc31475ddbd7944bc0f6e8215e332e359b08/
Whiteboard:
Fixed In Version: sssd-2.0.0-29.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-14 01:17:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Madhuri 2018-12-03 08:30:55 UTC
This bug has been created based on an anonymous crash report requested by the package maintainer.

Report URL: http://faf.lab.eng.brq.redhat.com/faf/reports/bthash/65a7dc31475ddbd7944bc0f6e8215e332e359b08/

time:           Mon 03 Dec 2018 03:25:02 AM EST
package:        sssd-proxy-2.0.0-23.el8
reason:         proxy_child killed by SIGABRT
cmdline:        /usr/libexec/sssd/proxy_child -d 0xf7f0 --debug-timestamps=1 --debug-microseconds=0 --logger=files --domain PROXY --id 1
executable:     /usr/libexec/sssd/proxy_child
component:      sssd
uid:            0
username:       root
hostname:       auto-hv-02-guest10.idmqe.lab.eng.bos.redhat.com
os_release:     Red Hat Enterprise Linux release 8.0 Beta (Ootpa)
architecture:   x86_64
pwd:            /
kernel:         4.18.0-48.el8.x86_64
abrt_version:   2.10.9

Reports:
uReport: BTHASH=65a7dc31475ddbd7944bc0f6e8215e332e359b08
ABRT Server: URL=http://faf.lab.eng.brq.redhat.com/faf/reports/bthash/65a7dc31475ddbd7944bc0f6e8215e332e359b08
ABRT Server: URL=http://faf.lab.eng.brq.redhat.com/faf/reports/9747/

Full Backtrace:
could not find '.gnu_debugaltlink' file for /var/cache/abrt-di/usr/lib/debug/usr/libexec/sssd/proxy_child-2.0.0-23.el8.x86_64.debug
[New LWP 24034]
Error while reading shared library symbols for /usr/lib64/sssd/libsss_util.so:
could not find '.gnu_debugaltlink' file for /var/cache/abrt-di/usr/lib/debug/usr/lib64/sssd/libsss_util.so-2.0.0-23.el8.x86_64.debug
Error while reading shared library symbols for /lib64/libbasicobjects.so.0:
could not find '.gnu_debugaltlink' file for /var/cache/abrt-di/usr/lib/debug/usr/lib64/libbasicobjects.so.0.1.0-0.6.1-39.el8.x86_64.debug
Error while reading shared library symbols for /lib64/libref_array.so.1:
could not find '.gnu_debugaltlink' file for /var/cache/abrt-di/usr/lib/debug/usr/lib64/libref_array.so.1.2.1-0.6.1-39.el8.x86_64.debug
Error while reading shared library symbols for /lib64/libcollection.so.4:
could not find '.gnu_debugaltlink' file for /var/cache/abrt-di/usr/lib/debug/usr/lib64/libcollection.so.4.1.1-0.6.1-39.el8.x86_64.debug
Error while reading shared library symbols for /usr/lib64/sssd/libsss_cert.so:
could not find '.gnu_debugaltlink' file for /var/cache/abrt-di/usr/lib/debug/usr/lib64/sssd/libsss_cert.so-2.0.0-23.el8.x86_64.debug
Error while reading shared library symbols for /usr/lib64/sssd/libsss_crypt.so:
could not find '.gnu_debugaltlink' file for /var/cache/abrt-di/usr/lib/debug/usr/lib64/sssd/libsss_crypt.so-2.0.0-23.el8.x86_64.debug
Error while reading shared library symbols for /usr/lib64/sssd/libsss_child.so:
could not find '.gnu_debugaltlink' file for /var/cache/abrt-di/usr/lib/debug/usr/lib64/sssd/libsss_child.so-2.0.0-23.el8.x86_64.debug
Error while reading shared library symbols for /lib64/libsss_certmap.so.0:
could not find '.gnu_debugaltlink' file for /var/cache/abrt-di/usr/lib/debug/usr/lib64/libsss_certmap.so.0.0.0-2.0.0-23.el8.x86_64.debug
Error while reading shared library symbols for /usr/lib64/sssd/libsss_debug.so:
could not find '.gnu_debugaltlink' file for /var/cache/abrt-di/usr/lib/debug/usr/lib64/sssd/libsss_debug.so-2.0.0-23.el8.x86_64.debug
Error while reading shared library symbols for /lib64/libsystemd.so.0:

Comment 1 Jakub Hrozek 2018-12-03 09:03:19 UTC
Thank you for the bug report, do you know how to reproduce this bug? Or were there any logs?

Comment 2 Madhuri 2018-12-03 09:11:33 UTC
Hello Jakub,

You can reproduce this bug by cloning the beaker job client/ldap_provider/case_sensitive
https://beaker.engineering.redhat.com/jobs/3190937

And log for above beaker job,
http://beaker-archive.host.prod.eng.bos.redhat.com/beaker-logs/2018/12/31909/3190937/6241900/85127061/taskout.log

Comment 3 Jakub Hrozek 2018-12-03 14:01:48 UTC
(In reply to Madhuri from comment #2)
> Hello Jakub,
> 
> You can reproduce this bug by cloning the beaker job
> client/ldap_provider/case_sensitive
> https://beaker.engineering.redhat.com/jobs/3190937
> 
> And log for above beaker job,
> http://beaker-archive.host.prod.eng.bos.redhat.com/beaker-logs/2018/12/31909/
> 3190937/6241900/85127061/taskout.log

Thank you, I cloned the test job and can reproduce the problem as well.

Comment 4 Lukas Slebodnik 2018-12-03 16:14:12 UTC
I assume crash is caused by forgotten TODO

https://pagure.io/SSSD/sssd/blob/6f113c7ddeaa5c82558e10118b499d22bf7a2b/f/src/providers/proxy/proxy_auth.c#_586

Comment 5 Jakub Hrozek 2018-12-03 22:35:43 UTC
(In reply to Lukas Slebodnik from comment #4)
> I assume crash is caused by forgotten TODO
> 
> https://pagure.io/SSSD/sssd/blob/6f113c7ddeaa5c82558e10118b499d22bf7a2b/f/
> src/providers/proxy/proxy_auth.c#_586

It's worse, the current version doesn't even get to this point, the proxy_child crashes even before because its D-Bus name is not compliant. It's tracked with a PR, at least. The todo is then the next thing that needs to be fixed..

Comment 6 Jakub Hrozek 2018-12-03 22:54:37 UTC
Upstream ticket:
https://pagure.io/SSSD/sssd/issue/3872

Comment 7 Jakub Hrozek 2018-12-04 07:58:48 UTC
Upstream ticket:
https://pagure.io/SSSD/sssd/issue/3892

Comment 8 Jakub Hrozek 2018-12-05 19:53:36 UTC
First part of the fix:
* f47940356462a3f477fe462e71d7680c959300db

Comment 9 Jakub Hrozek 2018-12-05 20:04:10 UTC
Second part of the fix:
* 807bbce25ffedb6f0d2d61831b5d5133e11aa84a

Comment 10 Michal Zidek 2018-12-11 20:05:23 UTC
I realized this is not QE acked so, I am moving this back to POST.

Steven, can you please QE ack this? The patches are ready (I even did a scratch build and wanted to push to OSCI when I hit the missing ack).

Comment 12 Madhuri 2019-01-16 06:29:07 UTC
Verified with:
sssd-2.0.0-38.el8.x86_64

Successful beaker without any crash,

case sensitive with openldap:
https://beaker.engineering.redhat.com/jobs/3287572

case sensitive with 389 ds:
https://beaker.engineering.redhat.com/jobs/3287573

From the above marking this bug as Verified.