Bug 1655787

Summary: No default network in libvirt when following RHEL8 docs
Product: Red Hat Enterprise Linux Advanced Virtualization Reporter: Jeff Nelson <jen>
Component: virt-80-moduleAssignee: Danilo Cesar Lemes de Paula <ddepaula>
Status: CLOSED ERRATA QA Contact: yalzhang <yalzhang>
Severity: low Docs Contact:
Priority: low    
Version: ---CC: chhu, ddepaula, dinechin, dyuan, ehabkost, jen, jsuchane, kanderso, knoel, laine, mtessun, tsorense, virt-bugs, xuzhang, yalzhang
Target Milestone: rc   
Target Release: 8.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: module-virt-8.0.0-820181206192524-9edba152 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1651312 Environment:
Last Closed: 2019-05-29 16:04:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1651312    
Bug Blocks:    

Comment 3 Danilo Cesar Lemes de Paula 2018-12-07 15:58:45 UTC
Fixed in module-virt-8.0.0-820181206192524-9edba152

We still need QA_ACK+...

Comment 4 yalzhang@redhat.com 2018-12-10 02:28:21 UTC
Verify on virt-module 820181206140226 - 9edba152, the package libvirt-daemon-config-network is added into the profile.

1. Fresh install, then module install virt:
# yum module install virt
....
======================================================================================================================================================
 Package                                        Arch            Version                                               Repository                 Size
======================================================================================================================================================
Installing group/module packages:
 libguestfs                                     x86_64          1:1.38.4-6.module+el8+2290+e39c271d                   beaker-AppStream          2.8 M
 libvirt-client                                 x86_64          4.5.0-15.module+el8+2285+e990ac42                     beaker-AppStream          322 k
 libvirt-daemon-config-network                  x86_64          4.5.0-15.module+el8+2285+e990ac42                     beaker-AppStream           22 k
 libvirt-daemon-kvm                             x86_64          4.5.0-15.module+el8+2285+e990ac42                     beaker-AppStream           20 k

>>>>>>>>>>>>>> The libvirt-daemon-kvm is added into the default profile

2. Start libvirtd and check the default network is active
# systemctl start libvirtd
# virsh net-list 
 Name                 State      Autostart     Persistent
----------------------------------------------------------
 default              active     yes           yes

# yum module info virt
...
Name             : virt
Stream           : rhel [d][e][a]
Version          : 820181206140226
Context          : 9edba152
Profiles         : default [d] [i]
Default profiles : default
...

Comment 5 yalzhang@redhat.com 2018-12-10 10:34:51 UTC
Sorry for comment 4 which is tested on the wrong stream 'rhel'. I have test on the '8.0.0' stream, the result is as expected.
And I have a question about step 5, "yum module install virt:8.0.0"  will not work as no default profile for 8.0.0 virt stream.
If there is any need to improve? It is none business with this bug, just to confirm. Thank you!

1. After fresh install
# yum module list | grep virt 
virt                 rhel [d]   default [d]                               Virtualization module                                              
virt-devel           rhel                                                 Virtualization module  

2. After enable the repo for 8.0.0 module: 
# yum module list | grep virt
virt                 rhel [d]   default [d]                               Virtualization module                                              
virt-devel           rhel                                                 Virtualization module                                              
virt                 8.0.0      default                                   Virtualization module        

3. check module info
# yum module info virt
...
Name             : virt
Stream           : rhel [d][a]  <====== the rhel stream is active by default
Version          : 820181206140226
Context          : 9edba152
Profiles         : default [d]
Default profiles : default
Repo             : beaker-AppStream
...
Name        : virt
Stream      : 8.0.0
Version     : 820181207185655
Context     : 9edba152
Profiles    : default
Repo        : ci_module
...

4. To install the virt module for 8.0.0 stream, need to enable it first.
# yum  module enable virt:8.0.0

# yum module list | grep virt
virt                 rhel [d]   default [d]                               Virtualization module                                              
virt-devel           rhel                                                 Virtualization module                                              
virt                 8.0.0 [e]  default                                   Virtualization module   

# yum module info virt
...
Name             : virt
Stream           : rhel [d]
Version          : 820181206140226
Context          : 9edba152
Profiles         : default [d]
Default profiles : default
Repo             : beaker-AppStream
...
Name        : virt
Stream      : 8.0.0 [e] [a]  <====== virt module for 8.0.0 stream is enabled and active now 
Version     : 820181207185655
Context     : 9edba152
Profiles    : default
Repo        : ci_module    <===== no default profiles as the rhel stream

5. try to install it, the libvirt-daemon-config-network is there.
# yum module install virt:8.0.0
Updating Subscription Management repositories.
Unable to read consumer identity
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Updating Subscription Management repositories.
Unable to read consumer identity
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Last metadata expiration check: 0:06:04 ago on Mon 10 Dec 2018 04:48:47 AM EST.
No default profiles for module virt:8.0.0
Dependencies resolved.
Nothing to do.
Complete!

# yum module install virt:8.0.0/default
...
======================================================================================================================================================
Installing group/module packages:
 libguestfs                                       x86_64       1:1.38.4-6.module+el8+2289+ec50a745                       ci_moudule1            2.8 M
 libvirt-client                                   x86_64       4.10.0-1.module+el8+2317+367e35b5                         ci_moudule1            326 k
 libvirt-daemon-config-network                    x86_64       4.10.0-1.module+el8+2317+367e35b5                         ci_moudule1             21 k
 libvirt-daemon-kvm                               x86_64       4.10.0-1.module+el8+2317+367e35b5                         ci_moudule1             19 k
...
Installing dependencies:
...

Comment 8 yalzhang@redhat.com 2019-03-01 06:00:55 UTC
As commnet 4 shows the package is inclueded and works well. Could we move this bug to verified directly? Thank you for confirmation.

Comment 9 Danilo Cesar Lemes de Paula 2019-03-04 14:20:54 UTC
Ideally the BZ has to be MODIFIED and moved to ON_QA when included in the errata.
But the AV process is a bit broken... so no problem.

Comment 11 errata-xmlrpc 2019-05-29 16:04:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1293