Bug 1656171

Summary: python-pip: Surpress warning about "new version of pip available"
Product: Red Hat Enterprise Linux 8 Reporter: Tomas Orsava <torsava>
Component: python-pipAssignee: Python Maintainers <python-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Maryna Nalbandian <mnalband>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 8.0CC: carl, jkejda, pviktori, torsava
Target Milestone: rc   
Target Release: 8.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-pip-9.0.3-12.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-14 01:38:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tomas Orsava 2018-12-04 21:26:10 UTC
Surpress warning about "new version of pip available" outside of venv.

pip by default detects newer version of itself and prompts users to install it using `pip install -U pip`. This is undesirable outside of a virtual environment, because we want users to rely on the packaged version of pip by default.