Bug 1656581

Summary: OpenStack Director Stack Fails to Deploy
Product: Red Hat OpenStack Reporter: bdeberry <bdeberry>
Component: openstack-tripleoAssignee: James Slagle <jslagle>
Status: CLOSED INSUFFICIENT_DATA QA Contact: Arik Chernetsky <achernet>
Severity: low Docs Contact:
Priority: low    
Version: 10.0 (Newton)CC: aschultz, bdeberry, mburns, sbaker
Target Milestone: ---Keywords: Triaged, ZStream
Target Release: ---Flags: aschultz: needinfo? (bdeberry)
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-12-17 21:41:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
templates and nic-configs none

Description bdeberry@cisco.com 2018-12-05 18:54:49 UTC
Created attachment 1511876 [details]
templates and nic-configs

Description of problem:

At one point I had a successful deployment then we made some additions to the templates and ever since that time stack deployment has failed. I have attached the templates, nic-configs, and script used for deployment. If possible to setup a WebEx to further look into the issue, please let me know and I can set it up.




I am now getting this error when attempting to do anything.

(undercloud) [stack@ense-undercloud ~]$ openstack stack list

Failed to discover available identity versions when contacting http://192.168.24.1:5000/. Attempting to parse version from URL.

Could not find versioned identity endpoints when attempting to authenticate. Please check that your auth_url is correct. Internal Server Error (HTTP 500)

(undercloud) [stack@ense-undercloud ~]$

(undercloud) [stack@ense-undercloud ~]$ openstack server list

Failed to discover available identity versions when contacting http://192.168.24.1:5000/. Attempting to parse version from URL.

Could not find versioned identity endpoints when attempting to authenticate. Please check that your auth_url is correct. Internal Server Error (HTTP 500)



Version-Release number of selected component (if applicable):

(undercloud) [stack@ense-undercloud ~]$ cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.6 (Maipo)
(undercloud) [stack@ense-undercloud ~]$ 
(undercloud) [stack@ense-undercloud ~]$ openstack --version
openstack 3.16.1
(undercloud) [stack@ense-undercloud ~]$ 


How reproducible:

Constantly

Steps to Reproduce:
1.
2.
3.

Actual results:

Stack fails to deploy.

After doing a recent update on the system, started receive the above errors "failed to discover.."

Expected results:


Additional info:

Templates and nic-configs are attached.

Comment 1 Alex Schultz 2018-12-05 22:59:36 UTC
The described issue seems to be related to accessing the services on the undercloud and not related to your overcloud deployment. It would be better if you could contact Red Hat support to walk though the issues rather than opening a Bugzilla for this.  One thing I would recommend is checking if you have any proxies set which might interfere with accessing the services. For example environment variables like http_proxy and https_proxy can interfere with the openstack commands.

We would need undercloud logs to further assist you but I believe Red Hat Support is a better place to work through the reported problems.

Comment 2 Steve Baker 2018-12-17 21:41:59 UTC
This can be reopened when the requested files have been provided