Bug 1656657

Summary: No secrets dropdown in buildconfig edit page if any of the secrets has no data
Product: OpenShift Container Platform Reporter: Yadan Pei <yapei>
Component: Management ConsoleAssignee: Jakub Hadvig <jhadvig>
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: medium Docs Contact:
Priority: low    
Version: 3.11.0CC: aos-bugs, jhadvig, jokerman, mmccomas, sgarciam, spadgett, wsun, yanpzhan, yapei
Target Milestone: ---   
Target Release: 3.11.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1633285 Environment:
Last Closed: 2019-01-30 15:19:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1633285, 1656660    
Bug Blocks:    

Comment 3 Yanping Zhang 2019-01-17 03:05:02 UTC
Tested on ocp env with version: v3.11.69
Steps to test:
1. Create app in project:
# oc new-app https://github.com/openshift/nodejs-ex.git
2. Create secret in project:
$ cat >secret.yaml <<EOF
apiVersion: v1
data:
kind: Secret
metadata:
  name: my-secret
type: Opaque
EOF
$ oc create -f secret.yaml
3. Check on bc edit page, there is secret dropdown list under each type of secret, eg, "Source Secret", "Pull Secret", "Push Secret", "Build Secret".


The bug has been fixed, so move it to Verified.

Comment 5 errata-xmlrpc 2019-01-30 15:19:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0096