Bug 1656659

Summary: No secrets dropdown in buildconfig edit page if any of the secrets has no data
Product: OpenShift Container Platform Reporter: Yadan Pei <yapei>
Component: Management ConsoleAssignee: Jakub Hadvig <jhadvig>
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 3.11.0CC: aos-bugs, jhadvig, jokerman, mmccomas, sgarciam, spadgett, wsun, yanpzhan, yapei
Target Milestone: ---   
Target Release: 3.11.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1633285 Environment:
Last Closed: 2019-01-30 15:19:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 1 Jakub Hadvig 2019-01-09 13:52:07 UTC
Fix merged: https://github.com/openshift/origin-web-console/pull/3082

Comment 3 Yanping Zhang 2019-01-14 06:23:00 UTC
Tested on ocp 3.11 env with version:
OpenShift Master:
    v3.11.69 
Kubernetes Master:
    v1.11.0+d4cacc0 
OpenShift Web Console:
    v3.11.69 
After created empty secret, checked on bc edit page, there was secret dropdown list under each type of secret.
The bug is fixed on 3.11, so move it to Verified.

Comment 5 errata-xmlrpc 2019-01-30 15:19:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0096