Bug 1656886

Summary: openscap-daemon requires dbus-python (Python 2)
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: openscap-daemonAssignee: Matěj Týč <matyc>
Status: POST --- QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 31CC: jcerny, matyc, mhaicman, mpreisle, simi+fedora, wsato
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Miro Hrončok 2018-12-06 15:36:49 UTC
openscap-daemon-0.1.10-4.fc29 requires dbus-python. Is it deliberate or a mistake? Note that dbus-python means python2-dbus, while the rest of the package requires Python 3.

Comment 1 Jan Černý 2018-12-06 15:51:52 UTC
Hi, this seems to be a mistake, and in my opinion there should be python3-dbus. The upstream sources are compatible with both Python 2 and Python 3.

Comment 3 Ben Cotton 2019-08-13 16:50:34 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 4 Ben Cotton 2019-08-13 19:37:37 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.